SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Custom board - /usr/make/sh command not found

Hi Joel,

Can you copy all the console output for more information about the problem ?

It seems that the build command is wrong. Did you change any settings ?
Please verify the following settings in the Project Properties > C/C++ Build > Settings > Tool Settings :

In MCU Settings :
- Prefix = arm-none-eabi-
- Path = ${openstm32_compiler_path}

In MCU GCC Compiler :
- Command = gcc

In MCU GCC Linker :
- Command = gcc

In MCU GCC Assembler :
- Command = as

If the values are valid, please create a new project with your custom board then build it immediatly. Does the build still fail ?

Kevin (ac6)

17:54:00 **** Incremental Build of configuration Debug for project netX EtherCAT ****
make all
Building file: C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/Common/cifXToolkit/User/TKitUser_Custom_STM32.c
Invoking: MCU GCC Compiler
arm-none-eabi-gcc -mcpu=cortex-m7 -mthumb -mfloat-abi=hard -mfpu=fpv5-d16 -DUSE_HAL_DRIVER -DSTM32F767xx -DUSE_STM32F7XX_NUCLEO_144 -DCIFX_TOOLKIT_HWIF -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/EtherCAT/Inc” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/EtherCAT/Inc/EtherCAT” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/Common/Inc” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/Common/cifXToolkit/OSAbstraction” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/Common/cifXApplicationDemo/Inc” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Drivers/CMSIS/Device/ST/STM32F7xx/Include” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Drivers/CMSIS/Include” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Drivers/STM32F7xx_HAL_Driver/Inc” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Drivers/BSP/STM32F7XX_NUCLEO_144” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Middleware/Third_Party/cifXToolkit/Source” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Middleware/Third_Party/cifXToolkit/SerialDPM” -Os -g3 -Wall -fmessage-length=0 -ffunction-sections -c -fmessage-length=0 -MMD -MP -MF”Middleware/cifXToolkit/User/TKitUser_Custom_STM32.d” -MT”Middleware/cifXToolkit/User/TKitUser_Custom_STM32.o” -o “Middleware/cifXToolkit/User/TKitUser_Custom_STM32.o” “C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/Common/cifXToolkit/User/TKitUser_Custom_STM32.c”
__/usr/make/sh: arm-none-eabi-gcc: command not found
make: *** Middleware/cifXToolkit/User/TKitUser_Custom_STM32.o Error 127__

17:54:01 Build Finished (took 790ms)

I have also encountered the same problems. all the set is the same with your reply , but it also turns out the error . please to see the last two lines of last reply .thank you !

my problem has solved . the china STM32 agency give me some help .
The error is caused by the system didn’t install the Eclipse for the C/C++ software.
The system workbench for STM32 software is integated on the Eclipse . so you must uninstall the system workbench for STM32,then install the Eclipse for C/C++ software , after it ,you can install the system workbench for STM32 , then the problem solved .