Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Custom board - /usr/make/sh command not found

Hi all,

This is my first post on this forum, so let me introduce myself: I’m software designer working in railroad factory. I’m used to program NXP and Atmel devices mainly but that’s the first time I’m using STM32 devices. We are trying to build a prototype with a MURATA LORA module which has a STM32L082.

I have downloaded and installed System Workbench for STM32, windows x64. I have created a new project “test” and realize I have to create a new “custom board” (why not). Done with the right device. Custom board name is “SENSELORA”. Then selected and downloaded the HAL. Project created, main.c contain the main function with the infinite loop, looks good :-)

But now clinking the hammer.... and failing to build the project :-( Error is “/usr/make/sh: DSENSELORA: command not found”.

I don’t understand what I can do now, so any help will be appreciate, probably something I’m doing wrong because I’m new to this environnement.

Thanks,
Joel

Hi Joel,

Can you copy all the console output for more information about the problem ?

It seems that the build command is wrong. Did you change any settings ?
Please verify the following settings in the Project Properties > C/C++ Build > Settings > Tool Settings :

In MCU Settings :
- Prefix = arm-none-eabi-
- Path = ${openstm32_compiler_path}

In MCU GCC Compiler :
- Command = gcc

In MCU GCC Linker :
- Command = gcc

In MCU GCC Assembler :
- Command = as

If the values are valid, please create a new project with your custom board then build it immediatly. Does the build still fail ?

Regards,
Kevin (ac6)

Hello kevin,

Thanks for your quick answer and your help.

Here is the console output:

10:10:53 **** Build of configuration Debug for project test ****
make all
Building file: ../startup/startup_stm32.s
Invoking: MCU GCC Assembler
D:R
/usr/make/sh: DSENSELORA: command not found
make: *** startup/startup_stm32.o Error 127

10:10:55 Build Finished (took 1s.523ms)


I haven’t chanegd any settings and I confirm that they are correct according to yours.
The project is just created, and I have tried to build immedialty. I haven’t modified the code, just trying to build the generated main.c provided by the environement.

  1. include “stm32l0xx.h”


int main(void)
{

for(;;);
}


I’m using the last version of System Workbench for STM32 (V2.1).

Thanks,
Joel

17:54:00 **** Incremental Build of configuration Debug for project netX EtherCAT ****
make all
Building file: C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/Common/cifXToolkit/User/TKitUser_Custom_STM32.c
Invoking: MCU GCC Compiler
C:\Users\xuyuyang\STM3_netX_F7_V1\Projects\STM32F767ZI-Nucleo\Applications\netX\EtherCAT\SW4STM32\STM32F767ZI-Nucleo\Debug
arm-none-eabi-gcc -mcpu=cortex-m7 -mthumb -mfloat-abi=hard -mfpu=fpv5-d16 -DUSE_HAL_DRIVER -DSTM32F767xx -DUSE_STM32F7XX_NUCLEO_144 -DCIFX_TOOLKIT_HWIF -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/EtherCAT/Inc” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/EtherCAT/Inc/EtherCAT” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/Common/Inc” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/Common/cifXToolkit/OSAbstraction” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/Common/cifXApplicationDemo/Inc” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Drivers/CMSIS/Device/ST/STM32F7xx/Include” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Drivers/CMSIS/Include” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Drivers/STM32F7xx_HAL_Driver/Inc” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Drivers/BSP/STM32F7XX_NUCLEO_144” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Middleware/Third_Party/cifXToolkit/Source” -I”C:/Users/xuyuyang/STM3_netX_F7_V1/Middleware/Third_Party/cifXToolkit/SerialDPM” -Os -g3 -Wall -fmessage-length=0 -ffunction-sections -c -fmessage-length=0 -MMD -MP -MF”Middleware/cifXToolkit/User/TKitUser_Custom_STM32.d” -MT”Middleware/cifXToolkit/User/TKitUser_Custom_STM32.o” -o “Middleware/cifXToolkit/User/TKitUser_Custom_STM32.o” “C:/Users/xuyuyang/STM3_netX_F7_V1/Projects/STM32F767ZI-Nucleo/Applications/netX/Common/cifXToolkit/User/TKitUser_Custom_STM32.c”
__/usr/make/sh: arm-none-eabi-gcc: command not found
make: *** Middleware/cifXToolkit/User/TKitUser_Custom_STM32.o Error 127__

17:54:01 Build Finished (took 790ms)

I have also encountered the same problems. all the set is the same with your reply , but it also turns out the error . please to see the last two lines of last reply .thank you !

my problem has solved . the china STM32 agency give me some help .
The error is caused by the system didn’t install the Eclipse for the C/C++ software.
The system workbench for STM32 software is integated on the Eclipse . so you must uninstall the system workbench for STM32,then install the Eclipse for C/C++ software , after it ,you can install the system workbench for STM32 , then the problem solved .


Do you have any special charaters in the System Workbench installation path or in the workspace path ?

Hello tang!

Match!! I had a special character in the workspace path, I have created a new workspace in C:\ and it is now building!

Thanks for your help,
Joel


 

Newest Forum Posts

  1. STM32429I_Discovery board with printf float support problem by johannes.visser@msc-technologies.eu, 16:08
  2. malloc heap issue with CubeMX Project by johannes.visser@msc-technologies.eu, 16:04
  3. Debugger not working by Daniel Jack Morley, 2019-11-27 21:46
  4. Compiler change problem by Lucian Pop, 2019-11-20 17:41
  5. Sample programs and compiling by jjtimer, 2019-11-20 10:31
  6. Unit test issues for STM32 by Rinkedevries, 2019-11-18 10:32
  7. Ubuntu 19.04 Debug problems by costantino, 2019-11-17 19:17
  8. Compile without eclipse by JSStabl, 2019-11-14 15:55
  9. Problem with PWM signal by ElectroniK, 2019-11-13 20:55
  10. Does System Workbench for STM32 work on a Raspberry Pi 4? by betocool, 2019-11-10 05:27

Last-Modified Blogs