Loading...
 

System Workbench for STM32


Error in building project

I have a STM32F401RE and a STSPIN230.
I’m trying to build the example project from the STSPIN230 firmware with some changes to the MC_SixStep_param.h.
The following error appears:

 arm-none-eabi-as -mcpu=cortex-m4 -mthumb -mfloat-abi=soft -g -o "Example\\startup_stm32f401xe.o" "..\\..\\..\\..\\..\\..\\..\\Drivers\\CMSIS\\Device\\ST\\STM32F4xx\\Source\\Templates\\gcc\\startup_stm32f401xe.s" 
Assembler messages:
Error: can't open ..\..\..\..\..\..\..\Drivers\CMSIS\Device\ST\STM32F4xx\Source\Templates\gcc\startup_stm32f401xe.s for reading: No such file or directory
 

Any ideas? The file is there and the paths are good.

Fixed: I tried building the project with SW4STM32 version 1.3 and it worked.

 

Newest Forum Posts

  1. Write option bytes by Just1M, 2019-04-24 11:34
  2. Write option bytes by ihouses, 2019-04-24 08:26
  3. Update vs. install version discrepency by christelle.burguera, 2019-04-23 10:06
  4. Variables by anthony@churchillnavigation.com, 2019-04-22 16:52
  5. Symbol 'SysTick_IRQn' could not be resolved by bart@engine27.be, 2019-04-22 12:56
  6. Update vs. install version discrepency by gbabecki, 2019-04-19 19:41
  7. failed to install drivers while tried to install STM32 workbench on windows 8.1 pro by saidattu32, 2019-04-19 19:13
  8. STemWin Trainning Video - Can't find lab file by agiles chroms, 2019-04-19 18:53
  9. System Workbench for STM32 v2.9.0 release by vionf, 2019-04-19 10:06
  10. Update vs. install version discrepency by dautrevaux, 2019-04-19 08:45

Last-Modified Blogs