Loading...
 

System Workbench for STM32


Ubuntu 18.04: Installer does not find JRE

Hi there,

trying to install sw4stm32 on my system:

Description: Ubuntu 18.04.1 LTS

Release: 18.04

Codename: bionic


I did try both v2.7 and latest vs Java 8 and Java 11:

java 11.0.1 2018-10-16 LTS

Java(TM) SE Runtime Environment 18.9 (build 11.0.1+13-LTS)

Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.1+13-LTS, mixed mode)



And

java version “1.8.0_191”

Java(TM) SE Runtime Environment (build 1.8.0_191-b12)

Java HotSpot(TM) 64-Bit Server VM (build 25.191-b12, mixed mode)


output is always :

install_sw4stm32_linux_64bits-latest.run: 34: install_sw4stm32_linux_64bits-latest.run: [: not found

install_sw4stm32_linux_64bits-latest.run: 67: install_sw4stm32_linux_64bits-latest.run: [[: not found
Checking integrity... (could take a while, -m to bypass)
Extracting JRE... done
install_sw4stm32_linux_64bits-latest.run: 124: install_sw4stm32_linux_64bits-latest.run: [[: not found
install_sw4stm32_linux_64bits-latest.run: 127: install_sw4stm32_linux_64bits-latest.run: [[: not found
No JavaRE found, please download and install JavaRE 7 (64 bits) or newer version.

Go to http://www.oracle.com/technetwork/java/javase/downloads/index.htmlQuestion


Do I need to downgrade to java7 ?

France

Looking at the messages above, it seems you don’t use bash as you login shell; could you try typing chsh at a command prompt and switch to /bin/bash if you have another shell?

Of course you must first check that bash is installed on your system by trying to execute it directly, or typing which bash

Then try again to install System Workbench for STM32

Bernard (Ac6)

Seems I am using /bin/bash already:

$which bash

/bin/bash


similar with chsh:

Enter the new value, or press ENTER for the default

Login Shell /bin/bash:

 

Newest Forum Posts

  1. Problem programming chip by JimELi, 2019-03-25 21:26
  2. CubeMT code, generated for SW4STM32 by market14, 2019-03-25 03:57
  3. Problem verifing and downloading code by strohmas, 2019-03-24 23:16
  4. Nucleo-144 TCP Problems by mklee, 2019-03-22 19:25
  5. CubeMX function pack development by ajcurtis84, 2019-03-22 18:59
  6. STM32CubeMX LWIP not working by leflingue, 2019-03-22 12:22
  7. STM32CubeMX LWIP not working by matsjuhlin, 2019-03-22 09:13
  8. STM32F746-Discovery by stanandrzej, 2019-03-21 12:41
  9. System Workbench takes up to five minutes to load by Servant, 2019-03-21 02:39
  10. How to use multiple ST boards simultaneously by Kevarek, 2019-03-20 19:21

Last-Modified Blogs