SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Debugging setup issue on ST discovery and eval board

Hi All,

I am a new user for SW4STM32 and struggling under debug configuration now.

Whenever I started debug, I can see the message below on console window and
dialog box saying “Program file does not exist”

“Open On-Chip Debugger 0.9.0-dev-00415-g2d4ae3f-dirty (2015-04-22-11:10)
Licensed under GNU GPL v2
For bug reports, read
Info : auto-selecting first available session transport “hla_swd”. To override use ‘transport select ‘.
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 2000 kHz
adapter_nsrst_delay: 100
none separate
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : Unable to match requested speed 2000 kHz, using 1800 kHz
Info : clock speed 1800 kHz
Info : STLINK v2 JTAG v21 API v2 SWIM v0 VID 0x0483 PID 0x3748
Info : using stlink api v2
Info : Target voltage: 2.852883
Info : stm32f4x.cpu: hardware has 6 breakpoints, 4 watchpoints”

I have tested this with STM32f429I-discovery and STM32f429_eval board and SW packages are

stm32cubef4 v1.6.0. and stm32cubef4 v1.7.0. The results were always same as above.

I just configured “Debug configuration” with default settings. Anybody can help me resolve this issue?

Actually, I was expecting there isn’t any trouble because I was using STMicroelecronics boards and SW packages.

ST-Link looks fine because I can download the binary file compiled by SW4STM32 using ST-Link utility.

Thank you in advance.

oops. I didn’t select target file.... After setting elf file, working...
Please help me, I am have the same exact issue. Where do I select the elf file? The elf file is in the Debug folder. Why doesnt OpenSTM32 know where the elf file that it created is. What is this nonsense? I have been wasting so many hours on this already.

You select the ELF file in the debug configuration first tab. You should just have to click on ‘Search Project’ after selecting th eright project.

By the way, if you select the project after having compiled it without error and then right-click “Debug As >> Ac6 STM32 C/C++ Application” (maybe after having deleted th enon-working configuration) should create a new configuration all set up correctly.

If this does not work, you should give more details on how you created the project (in SW4STM32 or by importing a CubeMX-generated project), what MCU you are targetting, what version of Syste Workbench you are using... BTW you may do a “Help >> Check for Updates” to be sure you use the last version of the tool; there may have been bug fixes.

Best regards,


Thank you Bernard. Linking to the elf file in the main debug C/C++ Application tab partially solved my issues. I got one of the STM32F4 cube example projects to run, although repeating the procedure with the other cube projects is failing. I either can’t get them compiled without errors, or if they do compile, and I debug/run, nothing happens on the micro-controller.

In general I find that openstm32 is buggy when it comes to STM32F4 cube. If I run the example projects in IAR Embedded Workbench, I never have any problems, but of course my demo version of that IDE expired, hence the need for openstm32.

If I create my own projects with my own source files from scratch in openstm32, I usually don’t have problems, its just the cube which makes me yell out loud with profanity in my office.

To answer some of your questions, I’m using STM32F429 with the 429 Eval board. All I want to do is run the example projects in STM32F4 cube using openstm32 in order to help me in my own development.


These are known problems with CubeMX (you didn’t mention the projects were created by CubeMX).
We hope ST will have corrected CubeMX SW4STM32 project generation in a forthcoming release of CubeMX (and then update the example projects delivered with their firmwares).
Thanks for your patience,

Has this been fixed in the year since? Running into a similar problem with an STM32F405.