SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Unable to build project


I’ve just imported a project and I’m having a lot of issues with it. When I tried to build it, a message appeared saying that there was nothing to build. I figured out that the toolchain and builder used are different than the ones I have downloaded (It used to be Ac6 STM32 MCU GCC and GNU make builder, both were designated as “orphaned” in the toolchain editor tab). (see attached file)

I tried to change these to ARM Cross GCC and Gnu Make builder but I only ended up with this error in the console :

15:22:01 **** Incremental Build of configuration Debug for project project1 ****
make all
Building file: ../Src/A_com_cartes.c
Invoking: GNU ARM Cross C Compiler
arm-none-eabi-gcc -mcpu=cortex-m3 -mthumb -O2 -g -std=gnu11 -MMD -MP -MF”Src/A_com_cartes.d” -MT”Src/A_com_cartes.o” -c -o “Src/A_com_cartes.o” “../Src/A_com_cartes.c”
../Src/A_com_cartes.c:9:26: fatal error: A_com_cartes.h: No such file or directory
Src/subdir.mk:84: recipe for target ‘Src/A_com_cartes.o’ failed
compilation terminated.
make: *** Src/A_com_cartes.o Error 1

15:22:02 Build Finished (took 924ms)

See attached file for problems tab

I’m on Windows 10, working with Eclipse Neon.3 Release (4.6.3)
Java : jdk1.8.0_144
GNU MCU Eclipse 4.1.1 (GCC 5.4)
board : STM32F401C-DISCO

I have no idea what’s going on, does anyone know how to solve this issue?


Hi GanLan,

Your project is an Ac6 project that means if you want to compile and debug this project you need to download the Ac6 plugins.
The toolchain “Ac6 STM32 MCU GCC” is included in Ac6 plugins that is why you have an “orphaned toolchain”.

I suggest you to install the Ac6 update site with this p2 software repository:
Then your project should compile normaly.


Thank you for your quick reply,

I have installed the toolchain you suggested through help >> Install New Software and I copied the link you gave me in the “work with” menu bar.
I selected every single options given in the download menu.
Unfortunately, the Ac6 toolchain remains orphaned... Any idea?


Hi GanLan,

Did you restart your eclipse after the installation of Ac6 plugins?


Hi Elliot,

It did restart automatically after the package download and I restarted it manually after your message but nothing changed.



Is it possible to check if the folder < workbench_installation_folder >/plugins/fr.ac6.mcu.externaltools.arm-none.win32_< version_number >/tools/compiler/bin is well present and not empty? (When you restart your workbench after installing the Ac6 plugins, the toolchain is unzipped there)

If the toolchain is present, try to close and reopen your project. If the pb persist try to remove and re-import your project.


Hi Elliot
I met the same problem as GanLan met. I trying to open the project : Sgfx_ModemAT (B-L072Z-LRWAN1)
I proceed as explained in this post, But I could’nt build my project.
Also, I can not reach the folder < workbench_installation_folder >/plugins/fr.ac6.mcu.externaltools.arm-none.win32_< version_number >/tools/compiler/bin

Any imcome form your part will be welcome.

Hi Elliot,

I removed and re-imported the project it now it works perfectly! Thank you very much for your assistance!

Best regards,



I’ve just created a new project and I’m having a lot of issues with it. When I tried to build it, a message appeared saying that ‘building is finished’.But lot of errors in console window. I figured out that binaries is missing under my file name in the project explorer. Please see the attachment showing the error message. Please reply.

The first thing that comes to mind is to develop a generic application in STM32Cube MX. There you can generate everything for the three development environments, and quickly add typical devices like the wolf run slot machine freeQuestion website. Well, that’s true, but:

If you look at the examples of applications, created through CubeMX, you will see, that after their automatic creation you still need to finalize them with a file. That is, time is saved but not to the maximum.
You must create a project for each development environment individually, although all three will be in the same working directory.
In today’s Cube MX environment I can not see the possibility of adding work via STemWin, while the texts are faster to output through it (when the article was uploaded to Hubr, but not yet published, I found that the restless STemWin has replaced by TouchGFX, but still the other two points are also weighty).

Actually this is enough to put this option in reserve and look around to see if there are simpler solutions... Turns out there are, and they’re also related to Cube MX. Everyone, who worked with this environment, knows, that it consists of basic code and packages, serving the specific family of controllers.

Betting on sports is an intellectual bet between a player and a bookmaker: the player makes a prediction about a sporting event and bets money that the prediction will turn out to be correct. If the bet is correct, he gets his money back with a profit, if he loses the bet, he loses it.
The bookmaker gives each bet a coefficient (quotation) assessing the probability of this event. If the bet turns out to be successful (the player’s prediction is correct), the betting amount is multiplied by the odds offered by the online bookmakers VICQuestion- this is the size of the payout due for a successful bet.