Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Problem with download “Standard Peripheral Library”

Hi,

I tried with the same board selected, and it was ok for me, I was able to download the library.

So, after having click on “Download target firmware” have you seen the “License agreement” dialog ?
If yes, after having accept and click ok, have you see anything at the bottom of the “Project Firmware configuration” dialog ?
a downloading progress bar message ? (see the attach screen
a extracting progress bar message ?

Can you verify if you have anything on c:\Users\user_name\AppData\Roaming\Ac6\SW4STM32\firmwares ?
you must have firstly the zip : stsw-stm32143.zip and after the extract you must have a folder : STM32_Nucleo_FW_V1.2.1


Christelle

Hi,

I have the same problem with download, but even after having click Download target firmware and then YES for license a download process doesn’t start. Have anyone resolve or fix the problem and could help how ?

Regards,

Peter

Hi,

I´ve got the same problem. I want to download the SPL Firmware for the Nucleo F103RB Board. After I agree the license agreement nothing happens, only a 210KB file gets created in the firmware directory, named stsw-stm32143.zip.
I already tried downloading it the manual way and extracted it to the folder STM32_Nucleo_FW_V1.2.1. The firmware is still not found. In the eclipse Error Log I can observe the error “Unhandled event loop exception”. If it helps I can upload a more detailed log.

By the way, the Eclipse version is updated. I hope someone can help me, thanks.

Hello,

Are you working on Ubuntu 16.04 ?

I recopy the FAQ answer:

This is a known Eclipse bug with the GTK graphical library on various Linux distributions (Ubuntu, Mint...).
Linux install GTK3 as the default library for all programs, thus Eclipse is running with GTK3, while it was coded for GTK2. To force Eclipse to use the older GTK2 version, you need to set the environment variable SWT_GTK3=0 before running Eclipse.
This can be done either in the environment (adding export SWT_GTK3=0 to your $HOME/.profile file) or by calling Eclipse as SWT_GTK3=0 /path/to/eclipse; you can also create a small script to start Eclipse.
Another way to use GTK version 2 instead of 3 is to modify the eclipse.ini file in the System Workbench for STM32 installation, adding
--launcher.GTK_version 2 before -showsplash

Hi,

sorry I forgot this information. I am working on Windows 8.1 x64.

Hello,

Did you let the zip file in c:\Users\user_name\AppData\Roaming\Ac6\SW4STM32\firmwares directory ?
I think SW4STM32 checks that the zip is there first.

Did you update the plugins, menu Help => Check for Updates ?
v1.11.0 is the latest version.

Which Eclipse version are you running ?

Rgds,
Laurent

France

Hello,

In sync. with Laurent’s post.

In order to get your firmware repository identified you have :

1) To get STM32_Nucleo_FW_V1.2.1 directory available under your firmware repository area
2) To get stsw-stm32143.zip source file available under your firmware repository area TOO

Tips : Firmware repository area is c:\Users\AppData\Roaming\Ac6\SW4STM32\firmwares by default. Such default can be updated Thks SystemWorkbench preferences

Once all such is ok if your firmware is still not found, my advice would be to refresh internal firmware finder closing & opening back new project creation wizard.

Rgds,


Also the same problem - Ubuntu version for STM32F407 - the System Workbench get stucked after pressing download ang lic acknowledgement. Solution is needed!!!

fuck off - the solution is here:

Question: Why does the IDE freeze when accessing to the build settings (Properties > C/C++ Build > Setting) on Linux ?
Answer

This is a known troubleshooting Eclipse bug with the graphical library on Linux distribution (Ubuntu, Mint...).
Eclipse is running with GTK3 by default. To force, Eclipse to use the older GTK2 version, you need to set the environment variable SWT_GTK3=0 before running Eclipse.