SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Problem with download “Standard Peripheral Library”

When I create a new C project in System Workbench for STM32, on the screen “Project Firmware Configuration”, when I chose “Standard Peripheral Library” and try download it, nothing is cheapen. If I chose “Hardware Abstraction Layer” everything is ok. How I can solve this problem?
IMG 579cc5078079d3330

Hi !

which board do you use?
which version of the plugins do you have (Help=>About Eclipse : click on openSTM32 icon (blue butterfly)) ?

I think it is 1.8 version

yes you’re right.

firstly, upgrade your SW :
- click on Help > check for Update
- select all the fr.ac6.... plugins
- follow the process untill the SW ask you to restart

secondly, which board do you use to create your project ?



Unfortunately, after update SW, nothing has changed.
I have STM32 Nucleo-64 development board with STM32F103RB MCU and the same is chosen from the list in the project configuration.


I tried with the same board selected, and it was ok for me, I was able to download the library.

So, after having click on “Download target firmware” have you seen the “License agreement” dialog ?
If yes, after having accept and click ok, have you see anything at the bottom of the “Project Firmware configuration” dialog ?
a downloading progress bar message ? (see the attach screen
a extracting progress bar message ?

Can you verify if you have anything on c:\Users\user_name\AppData\Roaming\Ac6\SW4STM32\firmwares ?
you must have firstly the zip : stsw-stm32143.zip and after the extract you must have a folder : STM32_Nucleo_FW_V1.2.1



I have the same problem with download, but even after having click Download target firmware and then YES for license a download process doesn’t start. Have anyone resolve or fix the problem and could help how ?




I´ve got the same problem. I want to download the SPL Firmware for the Nucleo F103RB Board. After I agree the license agreement nothing happens, only a 210KB file gets created in the firmware directory, named stsw-stm32143.zip.
I already tried downloading it the manual way and extracted it to the folder STM32_Nucleo_FW_V1.2.1. The firmware is still not found. In the eclipse Error Log I can observe the error “Unhandled event loop exception”. If it helps I can upload a more detailed log.

By the way, the Eclipse version is updated. I hope someone can help me, thanks.


Are you working on Ubuntu 16.04 ?

I recopy the FAQ answer:

This is a known Eclipse bug with the GTK graphical library on various Linux distributions (Ubuntu, Mint...).
Linux install GTK3 as the default library for all programs, thus Eclipse is running with GTK3, while it was coded for GTK2. To force Eclipse to use the older GTK2 version, you need to set the environment variable SWT_GTK3=0 before running Eclipse.
This can be done either in the environment (adding export SWT_GTK3=0 to your $HOME/.profile file) or by calling Eclipse as SWT_GTK3=0 /path/to/eclipse; you can also create a small script to start Eclipse.
Another way to use GTK version 2 instead of 3 is to modify the eclipse.ini file in the System Workbench for STM32 installation, adding
--launcher.GTK_version 2 before -showsplash


sorry I forgot this information. I am working on Windows 8.1 x64.


Did you let the zip file in c:\Users\user_name\AppData\Roaming\Ac6\SW4STM32\firmwares directory ?
I think SW4STM32 checks that the zip is there first.

Did you update the plugins, menu Help => Check for Updates ?
v1.11.0 is the latest version.

Which Eclipse version are you running ?




In sync. with Laurent’s post.

In order to get your firmware repository identified you have :

1) To get STM32_Nucleo_FW_V1.2.1 directory available under your firmware repository area
2) To get stsw-stm32143.zip source file available under your firmware repository area TOO

Tips : Firmware repository area is c:\Users\AppData\Roaming\Ac6\SW4STM32\firmwares by default. Such default can be updated Thks SystemWorkbench preferences

Once all such is ok if your firmware is still not found, my advice would be to refresh internal firmware finder closing & opening back new project creation wizard.


Also the same problem - Ubuntu version for STM32F407 - the System Workbench get stucked after pressing download ang lic acknowledgement. Solution is needed!!!

fuck off - the solution is here:

Question: Why does the IDE freeze when accessing to the build settings (Properties > C/C++ Build > Setting) on Linux ?

This is a known troubleshooting Eclipse bug with the graphical library on Linux distribution (Ubuntu, Mint...).
Eclipse is running with GTK3 by default. To force, Eclipse to use the older GTK2 version, you need to set the environment variable SWT_GTK3=0 before running Eclipse.

Yes “License agreement” dialog pops up, but after that it doesn’t appear a progress bar .Firmware’s folder contain only STM32Cube_FW_F1_V1.3.0 and STM32Cube_FW_F1_V1.3.1 (folder and zip) I reinstall all components (drivers, java, SW) and when I try download “Standard Peripheral Library” the error message appeared
I have second computer with 32-bits Windows7, and on it everything works well, is it possible that the program won’t work well on 64-bits Windows7?.

Hi Bastik,

We support win7 64 and I’m using win7 64 without any isssue.
it seems to be an Eclipse’s issue.

To you use to all-in-one install or do you install firstly an Eclispe and after our plugins ?
In the to two cases :
- all-in-one 64 bits ?
- which version of Eclispe is ?

Thank you

I have exactly the same problem running on 64-bit Ubuntu Linux. I have the latest version of SW4STM32 and lib2lcurses32. I have tried creating a C Project for 9 different STM32 boards including F0, F3, F4, and F7 processors on both Nucleo and Discover boards. The result is the same; after approving the License Agreement, nothing happens. There is no internet activity, and the little disk on the screen keeps spinning. The SystemMonitor shows Java consuming about 20 % of the CPU time, while the “top” command shows Java running at 80% of the CPU time. The application does work on Windows 10 64-bit on all of the boards.

Hi !

Can you try to open the market place (Help>Eclipse MarketPlace) to test your network connections.
If you have access to the market place, can you attach your log file to show me the reported errors if exist (under your workspace.metadata.log)

Thank you

I’ve got the same problem; installed SW4STM32 from the windows installer (install_sw4stm32_win_64bits-v1.8.exe) yesterday (I’m on Windows 10). The details on the error say:

Internal Error:

The URL doesn’t exist (gives a 404 error) on the ST.com website, I’d guess this might be the issue? I had a quick look around on STs site, couldn’t find the zip file linked anywhere else... I’ve attached the log file containing the exception,


OK, so I’ve just tried downloading the CubeHAL instead of StdPeriph, and it seems to be downloading... Looks like this is the newest thing anyway, so I’ll probably persist with using the CubeHAL rather than StdPeriph!

I reinstalled the OS on my computer and everything works well. biggrin

I can confirm I have the same issue.

Windows 10
SW 1.8 downloaded today.

StdPeriph does not download but Cube HAL downloads and extracts OK.

Maybe ST have changed URL location as part of promoting Cube and phasing out their support of standard perihperal libs?