Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


sample program?

Got Workbench installed, built an empty project, it’s apparently running on my STM32F746G just fine. I’m sure I’m missing something obvious, but where are the samples? Even some basic like blinky would be good but bonus points for samples which demonstrate board features. I will look more tomorrow but thought I’d get something posted...

Thanks.


Thank you. That got me going just fine. I’m building and running samples just fine now.

What sample did you build?
Did you build it with SW4STM32? Sorry I don’t want to assume.
Did it build out of the box or did you have to relocate files or modify any code?

Sorry for all the questions but I have been completely unsuccessfull in building and running any of the projects for STM32F746G Discovery in SW4STM32 as yet even after extensive tracking down of include path issues and a little code modification.


1. Download and unzip the STM32CubeF7 http://www.st.com/content/st_com/en/products/embedded-software/mcus-embedded-software/stm32-embedded-software/stm32cube-embedded-software/stm32cubef7.htmlQuestion
2. Unzip (it’s big)
3. Launch Eclipse aka Workbench
4. Do File -> Import -> Existing Files into Workspace
5. Nav to ...\en.stm32cubef7\STM32Cube_FW_F7_V1.4.0\Projects\STM32746G-Discovery\Examples\BSP\SW4STM32\STM32746G_DISCOVERY
6. It should show one selected project
7. Say OK, then build that project
8. connect your STM32 via USB
9. next do Run -> Debug As Ac6 STM32 C/C++ Application
10. Hit the green arrow continue button as it always hits a breakpoint on main
11. Your LCD on the device should light up and then hitting the blue user button should step you thru various demos

If you want to run other demos you’ll need to delete the existing one from your workspace as they apparently all have the same name. Don’t delete from the file system obviously, just from the workspace.

I’m on day 2 with Workbench so I’m probably doing things the hard way...

Hi,
Unfortunately, after step 7, I get a message in Eclipse Neon saying “Invalid project path: Include path not found (G:\Werkplaats\STM32CubeF7\en.stm32cubef7\STM32Cube_FW_F7_V1.4.0\Projects\STM32746G-Discovery\Examples\BSP\SW4STM32\STM32746G_DISCOVERY\Debug).”, what am I doing wrong? Thanks for your reply.


To be explicit, no I didn’t have to move any files or fiddle anything. It was a bit non-intuitive to me to do that “import” thing as I’m more used to Visual Studio and the concept of just opening an existing project. But and Eclipse friend helped me figure stuff out.

Wonder on ‘til truth makes all things plain.
I have been approaching this all wrong. I have been trying to setup the project in the workspace I created by using either CubeMX to create the BSP in my workspace and adding the project files for one of the examples or I have been trying to copy a project from the FW file to my workspace duirng import. Both fail to arrange the include paths correctly and/or leave behind code files that I have to hunt down. And still when I get it all in SW throws errors that I cannot seem to track down.

Thank You for your very clear and concise instructions.
You may want to add a note to make sure “copy projects into workspace” is NOT checked.

Also you do know that your code is being built in the area where the zip file was extracted.

Did you manage to compile, flash and run an example application from the STM32Cube_FW_F7_V1.4.0-archive (e.g. the BSP example) ? What workspace directory did you use? And how did you import the example project into Eclipse?

I have a STM32F746G-Discovery board and installed on my Windows-10 PC a Eclipse Neon - GCC ARM tool chain (according to a blogpost of Carmine Noviello : http://www.carminenoviello.com/2015/07/13/started-stm32f746g-disco/Question ). But now I have the problem that the BSP example from the “STM32Cube_FW_F7_V1.4.0\Projects\STM32746G-Discovery\Examples\BSP\SW4STM32\STM32746G_DISCOVERY”-archive will not compile, because of “Invalid project path, include path not found”. I hope you can help me a bit further, thanks!


Yes, I’m aware the code builds “in place.” Now I’m going to be trying to figure out the best way to do my own derivative projects. I suspect I’ll just work in the same tree and folder copy the example I want to start with. The rub will come if I want to modify any of the “system” stuff.

Any thoughts you have would be welcome.

Thanks.

Working on it. May be awhile. One of the problems is that the projects often depend on code not in the project tree, such as the code found in /Utilities/... The fact that it takes 4 minutes to get to Project>C/C++Build>Settings to edit paths and such is no help. I have resorted to modifying the .cproject (xml) file outside of eclipse and restarting eclipse as a work around.

I tried making an entirely new project using STM32Cube but that didn’t give me any of the board support package (BSP) stuff I wanted.

Then I just folder-copied the BSP project to a new dir and opened a project from there. But Eclipse is having all a furball still thinking (at least partially) it’s the old project in the old location.

It’s saying it can’t find main.c and gives a path into the old BSP dir. But that’s not where I’m running from. I can’t see anything in the .project or .cproject files that specifically reference BSP.

So I’m not feeling very helpful today... :-)


Btw, I’m now ignoring the “No source file found...” message as it doesn’t seem to be affecting things. I had some other issues caused by general strangeness of embedded development. I think I’m finally moving slowly ahead using the “folder copy” version of the BCP demo.

How does it know to find the Utilities stuff that is in the base of the repo?
I tried doing a copy project files and then importing the Utilities into the project and setting the includes which worked until I added the rk043fn48h include to Drivers BSP Components also near the base of the repo and then the compile started throwing a make error for nothing to do for target clean.


I left the tree intact and just work “in place.” If you look at the .project file and .cproject you see scary links to files like ../../../../../../../thingy.c and PARENT_6_ (which I’m assuming means the 6th parent dir). So rather then wrestle with those I’m trying to to disturb.

As I’ve indicated above Eclipse is still not totally happy but if I ignore the one warning about the “no source file found” things seems pretty OK.

Embedded development is a bit of a change for me again but I’m getting there. There are certain things I take for granted that don’t seem to be givens in embedded land (e.g. rocky support for floating point), but hey.

confundido