SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Confused about directory structure with STM32CUBEMX plugin and Eclipse

Somewhere I’ve taken a wrong turning and STMCUBEMX either generates code in the wrong place or fails to generate the project file(s)

I started my project (smt-test) in the STM32CUBEMX plugin, generated the code and then imported it into Eclipse using File->Import.
This created a directory tree like this:


and I could compile it, debug it etc.

I then started to add files using eclpse which put them wayyyyy further down in the directory hierarchy

files added by eclipse

Now when I make changes to the STM32CUBEMX project, either ‘main.c’ is updated in the wrong place or I get an error message about having a problem generating the project file(s).

Does anyone have a definitive set of instructions for the integration of STM32CUBEMX and Eclipse? and the continued use of the `MX plugin to maintain a project?

PS - why does this forum not have a ‘code’ formatting method?



This is a well known problem in CubeMX that generates the project file in a sub-directory then creates links to effective files from this directory.

This problem should be solved by the last release of CubeMX, so update your CubeMX tool/plugin and generate your project again, in another directory tree, then import this new project and it should work.

Bernard (Ac6)

PS: Regarding code formatting, bracket your code by inserting it between {CODE()} and {CODE} (for a code block) or between -+~np~ and ~/np~+-: the -+ and +- external pair cause text to be displayed in monospaced (code) font while the ~np~ and ~/np~ pair protect included characters (like -+) from interpretation as syntax markers

I’ve found a very simple (and more comfortable) solution to get around this problem:

Create 2 symbolic links in your filesystem in smt-test/SW4STM/smt-test:

1.: link to ../../Src
2: link to ../..Inc

Next in Eclipse exclude smt-test/Application/User from build.

From now on, you can create your source and headers as usual in Src and inc, and everybody is happy (including CubeMX)



Hi everybody,

To solve this problem, you should upgrade to the latest version of CubeMX, that now generates the project file at the root of the diretory tree generated by CubeMX, so that it’s now a lot more convenient...

Bernard (Ac6)

give my solution a try!

I’m also using the latest CubeMX.


Many thanks all for the clues - it sounds as though it is still very much a work-around, I’m surprised that Eclipse doesn’t have a project generation API that ‘MX could use directly.

So I’ll update ‘MX - click the ‘About’ button, nothing happens. Try Help->About - nothing happens. So much for finding out what version I’m running.

Back up from ‘MX into Eclipse proper and I find I’m running “STM32CubeMX com.st.microxplorer.feature.group STMicroelectronics” so I try to update.
“No updates were found”
I know the latest is 4.14 because I can see it on the ST web siteQuestion so is 4.13 so broken it can’t manage to update itself or do I have to do it via an archive? And when I download it its the same name as the old version?

I’m really going off ‘MX - it could be great but these problems are basic development 101.

I’ll report back when I have worked out how to upgrade ‘MX and see if things improve.

Success - not only is ‘MX working more like I expected, I’ve even got git & bitbucket to play as well.

Taken all morning but worth it ;)

Spoke too soon

Changed a clock spec in ‘MX, generated code and it produced code in the wrong location and complains (still!!) that the project file failed to be created.

I just recognized, that current CubeMX (4.14.0) has -thanksfully- changed the directory-structure in a more flat way.
All my sugestions above are obsolete.



comes this new directory structure only with the Eclipse plugin of CubeMX?

I’m using a stand alone CubeMX 4.14. For me nothing has changed regarding the directory structure since CubeMX 4.13.
That means, the files appearing in Ac6 are still links to real files in a completely different structure created by CubeMX when the project has been imported by ac6


It only matters in SW4STM.
The Structure of newly created projects (in eclipse) has changed.


More problems with the ‘MX integration - put the project into git and the ioc file, drivers etc are too high up the directory tree so don’t get included. This makes it impossible to re-create on another machine after a checkout.

Someone at ST has a lot of work to do... is there a bugzilla or whatever to report and track this sort of problem?