SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Issue with compiling after changing Cube Configuration

I want to ask one question, becouse I’ve got some problems with my stm workbench. I created new project in Cube MX, use nucleo F072RB Board, set default configuration and generate code.
Then I imported this project into STM Workbench, wrote simple program to flash board led LD2 - everything goes ok.

Then I made litle changes in the Cube configuration, generated code, chose in STM Workbench:
Project: Clean
Project: C/C++ Index: Rebuild
Project: C/C++ Index: Freshen all files
After compilation everything goes ok.

Now problem starts.
I made more changes in Cube configuration - I added new UART and 6 GPIO pins. Then I generated code, goes to STM Workbench, tried to build it and I’ve got this:
Every time I try tu build my project, output hex file has got 8 bytes and of course - it doesn’t work. I tried to change configuration, change building settings, but the result was stil the same.

I want to ask, if someone have got simmilar issue and know, how to fix it.

(Sorry, if my english knowledne isn’t good enough).

Hello friend, I am also having the same problem, I think it is something related to win 10 64bits, I could not find a solution so far, in ubuntu it works correctly

I found the problem, when we regenerate the code in cubeMX the linker goes blank, is to generate a new linker configuration and copy that recompile normally, the problem is in cubeMX