SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

subdir.mk failure. Unexpected "("

Please help out a noob. I keep getting this error and I have no cleu what to do.

00:09:50 **** Incremental Build of configuration Debug for project Sys89 ****
make all
Building file: ../Src/dma.c
Invoking: MCU GCC Compiler
c:/ac6/systemworkbench/plugins/fr.ac6.mcu.externaltools.arm-none.win32_1.15.0.201708311556/tools/make/sh: syntax error: unexpected “(”
Src/subdir.mk:52: recipe for target ‘Src/dma.o’ failed
make: *** Src/dma.o Error 2

00:09:52 Build Finished (took 1s.819ms)

I have had the same problem for days. Would love to get some responses!
I’ve tried addind the ‘’ around weak and packed as explained here to no avail


found something usefull here:


Workaround #2:

Navigate to /plugins/fr.ac6.mcu.externaltools.arm-none.win32/tools/make;
Make a backup of the folder;
Remove the files:







I didnt have all the files in my folder, but deleting the ones i had that matched the list made the build complete. Dont know if it has any negative repercussions though..

I am unable to build project and got the error.
Earlier i used build successfully and i did not change any project setting, still i am getting this error.
Uninstalled and installed the IDE.

Am Developing my project by STM32Cubemx and System workbench am getting the same error

c:/ac6/systemworkbench/plugins/fr.ac6.mcu.externaltools.arm-none.win32_1.17.0.201812190825/tools/make/sh: syntax error: unexpected “(”
Src/subdir.mk:30: recipe for target ‘Src/main.o’ failed
make: *** Src/main.o Error 2

Please suggest any solution


Do you use Unix-type environment (such as cygwin) ? I think it run the wrong executable”make”.