SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Mac OS sierra version 10.12.6 won't install the .run installation file

My Mac cannot open the “install_sw4stm32_macos_64bits-v2.3.run” file; see attached. Do I need to download another kind of software to be able to open .run files?


I carried out this steps and it worked fine for me:

  1. Open a terminal session to Installer File.
  2. Run chmod +x For instance, on MacOSX this would be chmod

+x install_sw4stm32_macos_64bits-v2.3.run

  1. Execute the installer by running the installation file. For example, on MacOSX

./ install_sw4stm32_macos_64bits-v2.3.run

For the second point tells me that there is no file or directory of that type.


I’m new to MCUs and Workbench, just encountered the same problem this morning.

Here’s what I did:

First make the file an executable
$ chmod +x install_sw4stm32_macos_64bits-v2.7.run

Then run it. (./ at the beginning is required)
$ ./install_sw4stm32_macos_64bits-v2.7.run*

The advice from jLn_38 and ncertad worked for me on macOS High Sierra 10.13.6 (is there a way to give points/upvote?), although be aware that the installation may freeze at step two when it is waiting for a password in the terminal, but it’s not obvious why it has stopped.
It is a security feature in terminal (in both Mac and Linux) not for the password to be shown. not even *** for the number of chars typed. Just type your password and press Enter. The installation should continue.