SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Re: Re: workspace woes how to add a project

Thanks. Got the project inported.
I was at that dialog before, but had no idea what to do with it.

To make this simpler for someone, it should give the most common things as click boxes.

Existing project should not be hidden under “general”. IT should be in the list above general, or have a checkbox. The other common tasks should be there too.

So now I got it compiled, picked debug and can’t figure out how to download.
There should be two buttons that are not there.
1. Connect that would allow you to select the connection and connect to the board, with an indication as to when you are connected, i.e. the software can talk to the debugger.
2. a download to the device button.

The project created an .elf file. Of course the STM32F411 nucleo board is set up for a bin file, using
mbed, but that is not going to have the debug information,

So how do you download the code into the nucleo board so you can open and step at the source level?

Sure these are questions that are being asked by someone new to Eclipse. But they are not in the FAQ.. Just for the record, I’m an ebedded firmware developer with a medical device company. I’ve been doing this for 30 years. All the way back to 6805, 8031, 6502 days. So I’m not a noob to embedded, but this journey that has been going on for nearly 2 months, just to be able to get a test program to compile and be able to debug it as been a complete nightmare.
CooCox doesn’t support it.
Embed doesn’t have debugging capability other tha 1980’s serial print facility (typically the first thing one does with a new embedded project, but passe today)
Emblocks compiled but produced an empty file
There were a couple more that I tried to no effect.
Then the FAE turned me to openSTM32 and I have been trying to get it to work for several weeks.
AsI related, projects had errors, couldn’t find a way to change projects.
Changing projects is still not something that I know how to do yet.



To download and debug your program, you should just select your project, then using the context menu (right click) select “Debug As >>> Ac6 STM32 C/C++ Application” (also available from the Run menu) and it should automatically download your program, start it (with a breakpoint set at main) and switch to the Debug perspective, where you will be able to single step your code, set or remove breakpoints, look and modify variables...

To come back to the normal C/C++ perspective, just click on the “C/C++” button on top right of the window.

By the way, dit you read the various documentation pages on the web site? If not I advise you to read and practice the Getting started with System Workbench for STM32 guide as well as all the pages under System Workbench for STM32

Thanks for your patience,