SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

java version needed

Hi, I beleive I have the lates JAVA installed on my PC, but still I get message: Java strated but returned exit code=13. Then many lines of log of the error.

my version is 7 update 71 (build 1.7.0_71-b14).

Can you help?

thanks, Jiri

I can’t put here the image directly thorugh icon on the edit tab, because the forum gives me error: permision denied :-(


Probably you have the wrong type of Java installed; if you install the 64-bits version of System Workbench for STM32, you must have the 64-bits version of the Java JRE or JDK installed. If you have the 32-bits version installed, the installer will not complain (as he does not know if your java is 32 ou 64 bits, as it works) but Eclipse will not be able to run.

If this is the problem, please remove all 32-bit versions of Java and install the latest 64-bits version of Java you need (JDK or JRE).

For adding images to forums, this is currently not possible but will be added in a future version of the web site. Currently you should attach the image to your post using the Attach file feature below.


hi Bernard,

you were right, the 64-bit version did the fix! fortunately i can run both 64 and 32 bit version together. I need the 32-bit for other SW.

Would be nice if the environmnet would give a more readable message than I got.



I know this is abit old thread but in case someone needs to have both java versions installed and faces this problem.
You can add lines:

full path\javaw.exe

to the eclipse.ini file and thus select the java version you need to use.
usual paths are something like:
C:\Program Files\Java\jre7\bin (64bit)
C:\Program Files (x86)\Java\jre7\bin (32bit)


Hi, I installed Eclipse on my MacBook if I start up the SystemWorkbench.app I get the error:

Version 1.6.0_65 of the JVM is not suitable for this product.
Version: 1.7 or greater is required.

On my MacBook I have JAVA 1.8.
Does Eclipse works with JAVA version 1.8 or do I need version JAVA 1.7?

I run OSX version 10.12.3 and XCODE version 8.2.1.



Is this thread dead?

I have the same problem on ARM8(Nvidia TX2). I installed Oracle Java 8, the version is 1.8.0_161, but it says it is 142:, and then I tried with opensdk version 1.8.0_151, the same.