SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Help for a beginner ! cube to SW4AC6


Hi everybody,

I am new is STM32 world ! I come from the world of PICs in 8bits.
I have bought a board , NUCLEO-F429ZI.

to begin, I simply search to blink a led with differents possibility .

First one , with mbed on internet I have no probleme , it’s work fine ! I can change the duration of delay.

Second one , i would like use STM32CubeMX to configure my board, and import the empty project in SW4AC6 .

After several attempts and in different ways, I cannot get my led.
I have tried creating a project in cube and opening it directly in SW4AC6.
I tried saving the cube file and then importing it into SW4AC6.
I add some kigne of code to flash my led.

Nothing to do !

Would someone be kind enough to guide me to successfully flash my led under SW4AC6? the top would be with a configuration made by cube and then the code on SW4AC6.

Sorry for my English but I’m French!

Best regards,


Good morning all,

I must be really stupid .... 2 days without being able to flash the led with SW4STM32 and cubeMX on a NUCLEO-L476RG or NUCLEO-F429ZI card!
I expected 32 bits to be more complicated, but not that much!

And I strongly advise against throwing it in there. so-called simple cards to implement, I must be too dumb, and I throw in the towel.

Hello Jeremy,
I’ve been in your shoes many times. Too long to do simple things when starting or doing things at least twice. It is quite frustrating.
I’m new at this too, but let me ask you, when you import, do you import “Existing Projects into Workspace”

Not easy. No help but always be on your own.