SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

[SOLVED] Debug FreeRTOS under SW4STM32 fail.

Solved it myself.
Excuse me for concern.

Hi everything!
I successfuly compile my FreeRTOS based project under SW4STM32. I configure OpenOCD for work with FreeRTOS. But when try debug app (click Resume button) I get error in gdb console:

New Thread 1
Note: automatically using hardware breakpoints for read-only addresses.
New Remote target
Switching to Remote target
Invalid selected thread.

While debug from command line work fine.
What could be the mistake?