Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


gdb not connected to openocd for debug

I have SW4STM32 with last updates on win10 PC. But debuging with ST-Link don’t work.

Debugging worked ok on my PC one month before.

I check hardware - st-link erase and program mcu througth menu Project->taget - ok/
I check hardware - keil debug on this hardware on my PC.
If I run gdb from win-console and command “target extended-remote localhost:3333” while openocd started from eclipse debug and wait connection - connection to mcu sucssed for gdb from win-console.
If I connect st-link to my laptop (win10) debuging work on my laptop.

I tried remove avast from my pc, delete and install SystemWorkbench, install STM32CubeIDE, atollic - with all gdb not work. Debug with keil on my PC work ok.

I think problem with my os + gdb but I don’t know how fix it.

UPD: Problem in old deleted COMODO CIS, debugger work ok after deleting of comodo driver in Ethernet card property .