Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


You are viewing a reply to Debugger does nothing  

Debugger does nothing

Error in final launch sequence
Failed to execute MI command:
-target-select remote localhost:3333

Error message from debugger back end:
localhost:3333: The system tried to join a drive to a directory on a joined drive.
localhost:3333: The system tried to join a drive to a directory on a joined drive.

Of course I created a debug configuration of the Ac6 STM Debugging type. I’m not sure what you mean about targeting a board. You target a processor; the IDE isn’t going to know anything about our proprietary board.

I have created a debug configuration in STM32CubeIDE and have been using that to connect to the target and load the image built in SystemWorkbench.

France

When you create a SW4STM32 project you have to specify a target board; when using a proprietary board you can create a custom board and will thn have to specify the exact SoC that is included on the board (and of course the board-specific initializations and definitions will have to be provided by your code, instead of being predefined by the firmware).

The errors you have seem to indicate that you have source paths in your imported project that reference locations on your vendor build system; that’s why it is usually better to create a new project, although you may have to manually translate compilation options. If you keep the existing project you should probably check in project properties >> C/C++ General >> Paths and Symbols that all paths in Includes, Library Paths and Source Location are workspace-relative paths or are based on Eclipse variables, for example ${ProjDirPath}, and only name existing paths on your system.

You should also check on C/C++ Build >> Settings that all settings are valid and check paths in the debug configuration, especially in the Source tab.

Bernard (Ac6)