Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Workbench Connecting -->to internet problems

Hello Everyone!

I am kinda new with the STM32 family (just bought a STM32F103RB) but today I was trying to configure my workbench to start using it but seems like I cannot connect it to the internet the detailed error which appears is this:*
Some sites could not be found. See the error log for more detail.
‘’Unable to read repository at http://sw-center.st.com/stm32cubeide/updatesite1/content.xml.Question
Address family not supported by protocol family: connect
Unable to read repository at http://www.ac6-tools.com/Eclipse-updates/org.openstm32.system-workbench.site/content.xml.Question
Address family not supported by protocol family: connect’’
Than asks me to configure my network...
My setup info:

STM32CubeIDE

Version: 1.2.0
Build: 5034_20200108_0926 (UTC)
(C) 2019 STMicroelectronics ALL RIGHTS RESERVED

Windows 10 Home 64 bit

Java Runtime Environment
jre1.8.0_241

PS: I thought it was a problem with the firewall but doesnt seem like I even tried to turn it off completely...
I would love some of your support I already tried almost everything for sure I forgot something although not sure what, :-(

Carlos

France

Hi Carlos,

Did you try to modify or add the software sites (repository) in CubeIDE?

If you did, please go to Window > Preferences > Install/Update > Available Software Sites . Edit STM32CubeIDE Releases and set location at http://sw-center.st.com/stm32cubeide/updatesite1Question

PS: This forum is intended for System Workbench for STM32, System Workbench is normally not supposed to run on CubeIDE. You might find more relevant answer on ST forums.
Best Regards,
Ayoub
AC6