Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Can't debug

Hello

I’ve been using my STM32L053 DISCOVERY board for a few months. It worked until yesterday. I wrote a program to write a 4 char array to eeprom, under my lecturers supervision, and suddenly my and four of my student mates boards “crashed“ during debugging session.

Those are the errors that we are getting:
E310  : Debug access failed - cannot read address 0xF0000FE4 (accsize ‘4’, AP ‘0’)
Error: Flash download failed - Target DLL has been cancelled

We tried reinstalling the drivers and restarting our computers. We also tried reflashing firmware with STM32CubePrg, changed debug connecting settings in project options - neither of the above works to solve our problem.

Anyone has any ideas how to solve this?