Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Can't download StdPeriph library during project creation

Hi,
I have a problem, and can’t download StdPeriph (or HAL) library when creating new project.

How it looks like? After clicking “Download target firmware” nothing really happens, no alerts, only visible thing is created an empty folder in AppData\Roaming\Ac6\SW4STM32\firmwares for every download attemp.

I have this problem after reinstalling system to win10 64 bit, before that, on 32 bit system everything worked. I have tried also on win7 on other laptop but also without success.

How I have installed my IDE? Newest Java and Eclipse, then installing SW4STM32 through Eclipse by link: http://ac6-tools.com/Eclipse-updates/org.openstm32.system-workbench.update-site-v2Question

I have tried installing StdPeriph manually but it didn’t work.

Any help?