Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


ST Link Server installation fails on macOS Catalina

Screen Shot 2019 10 13 At 2.23.25 PM

com.izforge.izpack.api.exception.IzPackException: An error occured
in java.lang.Thread.run() at Thread.java:748
in com.izforge.izpack.installer.unpacker.UnpackerBase.run() at UnpackerBase.java:236
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at UnpackerBase.java:273
Caused by: com.izforge.izpack.api.exception.InstallerException: File execution failed
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at UnpackerBase.java:251
in com.izforge.izpack.installer.unpacker.UnpackerBase.unpack() at UnpackerBase.java:438
in com.izforge.izpack.installer.unpacker.UnpackerBase.executeFiles() at UnpackerBase.java:930


I tried changing the installation folder since the root /Applications is now protected. That worked fine for the first half of the installation process, but the screenshot shows that the ST Link Server is still trying to use the default /Applications/Ac6/ folder which is now restricted on macOS Catalina.

For more on the macOS Catalina restrictions, see:
https://forums.developer.apple.com/thread/120314Question

ST developers need to keep up-to-date with those changes. The cause is that in Catalina Apple introduced r/o system partition, so any old installers that attempt to write there are now incompatible.

/Applications are now a link to r/w partition, but any other system directories are r/o

While st-link server writes client side files into /Applications some things are written to other system directories, so it fails.