SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

error while uploading : open ocd child process termination reason:unplugged target or stlink already in use or stlink usbdriver not installed

thankyou for your reply .
“i have already installed stlink drivers as they are automatically installed when we make new project”by this statement i mean that i have tried installing drivers which are available at the st.com also when we make a project in the workbench there is a option in the additional drivers section (in the attached picture ) to install drivers for the evaluatuion board. i have tried both but it dosent work.
i looked up into the /etc/udev/rules.d directory and all the required files are already there also i have installed libusb but nothing works.

Hi Again,

The “Additional drivers” are not drivers to install on your Linux but are the code generated in your project for the board to control USB devices. Anyway, this option is not what causing your problem.

Can you open a terminal then run “killall openocd” to kill every running OpenOCD connected to the ST-Link. Maybe one application is blocking access to the ST-Link.

By the way, do you have the same issue when running a debug session ?

thankyou for your reply,
i tried “killall openocd” command in the terminal, the terminal says openocd : no process found . yes i am having the same issue when running a debug session , this time console says :

Open On-Chip Debugger 0.10.0+dev-00021-g524e8c8 (2019-04-12-08:33)
Licensed under GNU GPL v2
For bug reports, read
srst_only separate srst_nogate srst_open_drain connect_assert_srst
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 8000 kHz
adapter_nsrst_delay: 100
Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Info : clock speed 8000 kHz
Error: open failed (no matching adapter found)
in procedure ‘init’
in procedure ‘ocd_bouncer’

one thing i want to mention is that although my board is powered yet i cant see it in the device manager of linu (ubuntu version : 18.04.2)
. a notification always popup on the screen when we connect something on the usb port but when i connect my board on the usb no notification is showed . i m not the expert but i think it is something related to drivers . i tried connecting it on a windows10 operating system same problem persist. the device manager is not even showing unknown device found under usb peripherals section eventhough i have installed all the drivers properly .