SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Getting started on OSX?

Good day,

Can any OSX users guide me in how to get System Workbench up and running under OSX Mavericks? wink

Thank you

Try to restart Eclipse, then go in File => New => Project… and select a C/C++ => C Project. (http://www.openstm32.org/Creating+a+new+project)
If you cannot find “Ac6 STM32 MCU Project” under the Project type“Executable”, it means the plugins installation has failed.

I just downloaded the lastest version of Eclipse C/C++ then follow installation steps and it works for me. Maybe you should re-install it from scratch.


just tried it again and still not working for me. software is installed.


Can you tell me which version of OSX and Eclipse are you using ?
And can you attach a screenshot of the window Help > Installation Details > Installed Software with the installed plugins version.


i use 10.11.3 MAC OS.

Eclipse IDE for C/C++ Developers

Version: Mars.1 Release (4.5.1)
Build id: 20150924-1200

Everything seems to be well-installed. It can also be a Java version issue. Which java version are you running ?

Does the project type not exist in the wizard or does the project creation process fail ?
Btw can you take a screenshot of Window > Preferences > C/C++ > New C/C++ Project Wizard (with every project type expended) ?

Sorry again.


I’m a MAC user running Windows inside a VM just to design boards and write my electronics code. I’ve finally managed to get rid of Altium using KiCad, so getting rid of Keil is the only piece missing.
I’d love to see this AC6 environment running smoothly with my J-Link pro probe natively on my macs.

Just tried it. It seems there is a requirement for Java 8. Mars, the current eclipse release requires Java 7, so I am not sur why there is a requirement for Java 8 ?

Any suggestions for a fix ?

SESSION 2016-01-29 10:26:12.375 -------------------

java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_US
Framework arguments: -product org.eclipse.epp.package.cpp.product -keyring /Users/emmanuelcarjat/.eclipse_keyring -showlocation
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -product org.eclipse.epp.package.cpp.product -keyring /Users/emmanuelcarjat/.eclipse_keyring -showlocation

ENTRY fr.ac6.mcu.externaltools.arm-none.macos64 4 0 2016-01-29 10:26:14.367

MESSAGE FrameworkEvent ERROR


org.osgi.framework.BundleException: Could not resolve module: fr.ac6.mcu.externaltools.arm-none.macos64 467
Unresolved requirement: Require-Capability: osgi.ee; filter:=”(&(osgi.ee=JavaSE)(version=1.8))”

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)


Thank you for the report, a MAC OSX plugins update has just been released with a JAVA7 compatibility as minimum.

Sorry for inconvenience. Please check for update and then the error log should not appear anymore.


Hi Kevin,

Thanks for the quick reply and fix. All installed and working. I still have an issue with the linker script (-T option). I see that the path for the script is a relative path, you wouldn’t know what is the base path ?



Following-up on my previous post. The link is relative to the location of the makefile. However the windows style \ directory separator does not work and it needs a unix style / separator.


Page: 2/2
1  2