Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Stm32mp1 Ethernet-over-USB connection

STM32WB version 2.9.1.2019050314
Linux version 4.15.0.72 64b
Eclipse version Neon.3 release 4.6.3
Java version 11.0.5 2019-10-15
Distro Linux Mint 19.2 Tina


I am using the discovery stm32mp1-157 and trying to follow the wiki tutorial. I have been able to build the is and load it and reboot. I have been successful in creating the gtk hello world, loading it to the board and running it. Now I am trying to do the OpenAMP_TTY_echo project. It compiles fine but when I try to start the debugger the connection fails indicating “Ethernet over usb0 connection” error. The target widget in the lower right corner cycles through Status:idle, Device: /dev/ttyACM0, Addr: 192.168.7.2, check host usb0 cfg!.

Has anyone else run into this?

I have tried to fix it by adding group permissions for dial out and try to user name but no change.
I suspect a permissions problem but cannot figure it out.
I also checked the board side using the serial connection in SWB4STM and verified That the eth address for the board is 192.168.7.2.
The serial connection is not active while trying to use the debugger.

I have tried both the newer LMint 19 and Ubuntu 18.x LTS releases and neither have a usb0 device. How is anybody using this?
Do we have to down grade to Ubuntu 16 to get it to work?


Hi,
Can you try to ping at 192.168.7.2 ? If it is alive, try to connect with ssh. I’m not sure but i suspect the ssh server is not running on the stm32mp157c discovery. Can you also attached screenshot of the debug configuration startup page (Run > Debug Configurations... > ST’s STM32 MPU Debugging > $configuration_name > Startup tab )?

Regards,
Kevin