Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


How to run "audio playback and record" in System Workbench

STM has an example project called “Audio playback and recording using the STM32F4DISCOVERY” - application note AN3997 was made to give instructions on how to use it. But even with this application note I can’t seem to get it to run.

When I open the project, System Workbench doesn’t recognise it as a C project. I tried to Configure and Detect Nested Projects and it set up two C projects: MEDIA_InFLASH and MEDIA_USB_KEY which are the workspaces for running the program with the internal flash and USB respectively. However, neither of these have src or inc folders and they both throw up a lot of errors. I tried setting up a new C project and copying across all the relevant subfolders and got more errors - missing include files, unrecognised functions and variables.

I’ve had a lot of frustration getting this example code to do what it’s intended for. Am I missing something obvious?

I have attached the application note.

Hi,

Where did you get the project? And is the project configured for System Workbench ?

The System Workbench-compatible project provided by ST often has a “SW4STM32” directory in it. If you can’t find this folder, it probably means it cannot be built with our toolchain.

You might need to create a new project from STM32F4DISCOVERY then add your sources files and configure the project settings if required.

Sorry not being able to give more help.
Regards,
Kevin.

The project was provided by ST but does not have the “SW4STM32” directory in it. The directories in the project folder are:

  • Binary
  • EWARM
  • inc
  • MDK-ARM
  • src
  • TrueSTUDIO


The project came in a set of STM32F4 Discoveryboard examples. Any chance you could point me in the right direction in terms of finding the System Workbench configured version?

Thanks for the help.

Hi,

I just found a newer version of the project on https://my.st.com/content/my_st_com/en/products/embedded-software/mcu-mpu-embedded-software/stm32-embedded-software/stm32cube-mcu-mpu-packages/stm32cubef4.license=1570044162743.product=STM32CubeF4.version=1.24.0.htmlQuestion

Import the project in {...}/Projects/STM32F4-Discovery/Applications/Audio/Audio_playback_and_record/SW4STM32/STM32F4-DISCO

It builds for me but I did not test on the board.

Hope it helps.
Kevin.