SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Error: init mode failed STM32WB55


I’m using an STM32WB55 Nucleo Board and tried to program it.

Now I get the following error message:

Open On-Chip Debugger 0.10.0+dev-00021-g524e8c8 (2019-04-12-08:48)
Licensed under GNU GPL v2
For bug reports, read
srst_only separate srst_nogate srst_open_drain connect_assert_srst
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
padded zone erase set to 1
adapter speed: 12000 kHz
adapter_nsrst_delay: 100
Info : clock speed 12000 kHz
Info : STLINK v2.1 JTAG v34 API v2 M25 VID 0x0483 PID 0x374B
Info : using stlink api v2
Info : Target voltage: 3.265135
Error: init mode failed (unable to connect to the target)
in procedure ‘program’
in procedure ‘init’ called at file “embedded:startup.tcl”, line 495
in procedure ‘ocd_bouncer’

    • OpenOCD init failed **

shutdown command invoked

The board is connected correctly and the jumpers are set correct as well.
I just opened the Cube MX, let the standard settings and generated the code.
Then i opened the Systemworkbench builded the code and tried to program.
So no code changes were made.

A friend of mine tried it as well, did the same procedure with the same board and it worked at his computer to programm. So I think I have the problem in my settings somewhere.

I already reinstalled the Systemworkbench twice but nothing helped.
It is possible to programm it by using the STLink Utility program but not in the Systemworkbench.

Can you help me please?

Thank you!