SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Ubuntu 19.04 Debug problems

Hi guys,

Did any of you had issues with debugging in Ubuntu 19.04?
I have this error message when I try to do this:

Could not determine GDB version using command: /home/red/Ac6/SystemWorkbench/plugins/fr.ac6.mcu.externaltools.arm-none.linux64_1.17.0.201812190825/tools/compiler/bin/arm-none-eabi-gdb --version
/home/red/Ac6/SystemWorkbench/plugins/fr.ac6.mcu.externaltools.arm-none.linux64_1.17.0.201812190825/tools/compiler/bin/arm-none-eabi-gdb: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

I cannot install lib32ncurses5 with this command because it doesn’t find it:
sudo apt-get install lib32ncurses5

On other sites it says that this has been replaced with lib32ncurses6

Do you have any idea how to solve this?


Solved it with the classic solution of a link...

sudo ln -s /usr/lib32/libncursesw.so.6 /usr/lib/libncurses.so.5
sudo ln -s /usr/lib32/libncursesw.so.6 /usr/lib/libtinfo.so.5

Good luck guys!

Thank you, that solved my issue on Debian Buster!