SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Target Firmware


I installed the tools successfully. When I created the new project and I tried to install the “Target Firmware” Please see below. It times out.
See both pictures below. It seems that the tool is unable to download the firmware. Is there a workaround ?


Hi Tarek,
Could you please attach again your screen shots? There was a glitch on the web site and they were not sent.

The picture attachment keeps failing. It will not attach.
This time it works... There was a typo in a directory name...

How do you fix/recover from “Firmware Null has been Found” ? Per picture above.

Hello Tarek,

May be there was an issue while downloading the library.

Could you check that in the folder “C:\Users\AppData\Roaming\Ac6\SW4STM32\firmwares”, you have :
- a file named “stsw-stm32072.zip”, and if so, what is it’s size ?
- a folder named “STM32L1_Discovery_Firmware_Pack_V1.0.3” ?



Hi Pascale,

The file named : sts-stm32072.zip exists and the size “6.32 MB (6,634,308 bytes)”
The fodler name STM32L1_Discovery_Firmware_Pack_V1.0.3 does exist from before
It is under

It seems that the System Work Bench for STM32 does find it.



Hello Tarek,

In the folder “C:\Users\AppData\Roaming\Ac6\SW4STM32\firmwares”, could you try removing
- “stsw-stm32072.zip”
- “STM32L1_Discovery_Firmware_Pack_V1.0.3_setup.exe”

Then try creating the project again.

Best regards,


HI Pascale,

Thank you for the help. I did what you suggested and I created a new project.
It builds fine and the problem is resolved.

I appreciate your help.



Hello. Ihave the same problem.

But the folder firmware is empty.
Could I had the files manually?



I am new user at STM32 development and SW4STM32. I didn’t succeed in creating a new project.
Impossible to download the target firmware and impossible to locate the previously mentionned directories.
Could you help me please ?

Hi Sylvain, Hi Sebastien,
May you check for updates : Help menu >> Check for Updates?

I have the same problem on Ubuntu 16.04.
What I have tried :
- delete installation and workspace directory.
- delete ~/.ac6 directory
- install with latest installer
- run and apply updates (or don’t - the result is the same)
- create C project for NUCLEO-F334R8.
- get to the ‘Project Firmware Configuration’ screen. Whatever I do here, it just hangs. If I choose StdPeriph or HAL it will hang downloading firmware (or even as soon as you select StdPeriph). If I choose ‘no firmware’ it will hang when I choose ‘Finish’.

It is just the wizard that hangs. If you try to close the wizard, a box comes up and tells you that you can’t close the wizard due to an ‘active operation’. The red square to stop the operation does nothing and you can’t close eclipse because the same message comes up.

Eventually, I give up and ‘killall java’ from a terminal. I can’t think what else I can try...



Could you try the Ubuntu-16 fix explained in this FAQ entryQuestion? It may solve your problem.

Bernard (Ac6)

Thanks for your suggestion. I have had to SWT_GTK3=0 in the past for other Eclipse installations on Ubuntu.

Actually, I just got it working by also deleting the ~/.eclipse directory.
Hopefully that won’t affect my other eclipse installations (LPCXpresso, Eclipse CDT) too badly !
Thanks for your help anyway...it’s working now.