SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Errors when i compile my project

Hello everyone, here are the errors I’m facing, I tried to solve them by looking on the forum but nothing worked, can anyone help me please?

I’m working with System Workbench on ECLIPSE Version: Oxygen.3 Release (4.7.3).

Errors description: (the image is attached)
•1: fatal error: machine/_default_types.h: No such file or directory

•2 : make: *** Projects/End_Node/bsp.o Error 1

•3: :recipe for target ‘Projects/End_Node/bsp.o’ failed