SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Debug Error

I am currently working with the STM32MP157C-DK2, and I cannot run the debug. I am running code generated by the STM32CubeMX, I also tried running debug on the OpenAMP_TTY_echo from the STM32CubeMP1 package, but I get the same errors. I tried reinstalling System Workbench, and my target is set up correctly.

I get a pop up error that says
Error in final launch sequence
Failed to execute MI command
Error message on debugger end:
Load Failed
Load Failed

and on the console I see

Open On-Chip Debugger 0.10.0+dev-01124-gbfb41e6 (2018-11-16-15:00)
Licensed under GNU GPL v2
For bug reports, read
debug_level: 1
cortex_a interrupt mask on
cortex_a interrupt mask on
cortex_a domain access control fixup on
cortex_a domain access control fixup on
none separate
adapter speed: 5000 kHz
adapter_nsrst_assert_width: 200
adapter_nsrst_delay: 200
none srst_pulls_trst
srst_only srst_pulls_trst srst_gates_jtag srst_open_drain connect_deassert_srst
Error: Could not find MEM-AP to control the core
ap 0 selected, csw 0x10006000
Error: Target not examined yet

undefined debug reason 7 - target needs reset
Error: Target not examined yet
Error: Target not examined yet
Error: Target not examined yet


It did not have the correct File Association for the .cpproject and .project files. You need to go to Windows -> Preferences -> (Expand) System Workbench -> File Association -> Click Install under System Configuration