SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

SWD option gone

My board only ever worked with SWD and today suddenly debugging stopped working.
This may have been caused by the recent system workbench updates...
I had to delete my cfg file because eclipse was emitting loads of java errors and crashing when I tried to look at the debugger settings.
After creating new settings, I only get the option of JTAG in the drop-down, no SWD.
If I select ‘user defined’ configuration script and select my old Debug.cfg (restored from git) I can debug fine so SWD is working but can’t be selected in the drop-down.
It’s not a show stopper for me but annoying anyway...
Thanks !

I have exactly the same problem! SWD is missing from the list. And this is in the newest, freshly instaled Workbench version, installed on a clean computer (by coincidence, I’m doing a full reinstall of one of my computers at the moment)

Something with STM32Cube 5.2 that doesn’t create the project right. I downgraded to 5.1 and it came back.

-in project explorer (left) right click on project > Debug As > Ac6 STM32 C++ Application
- if this doesn’t work, check the following:
- in project explorer (left) right click project > Debug As > Debug Configurations
- goto second tab ‘Debugger’
- Check that at Configuration Script the radio button ‘User Defined’ is selected
- the scriptfile path is ‘${ProjDirPath}/application_Debug.cfg’
- Press Debug to test this. Probably this will not work (Eclipse Bug).
- in project explorer (left) find this file, right click, open with, Text Editor
- on line 10, it should be

transport select “hla_swd”

- unfortunately Eclipse overwrites this with “hla_jtag” the first 2 times. You can see this when you check the git-changes. It should be ‘hla_swd’
- Open Debug Configurations, and check again that Configuration script is ‘User Defined’.
- Press Debug to test this again.
- Check the file again, it should now be ‘hla_swd’. If you debug this now, it should work.