Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


stm32g0x.cfg line 45 fails

I recently received the stm32g071rb nucleo and thought I would try programming it with the standard ac6 methods that I used for the stm32f401re nucleo board. However, programming stops at this line:

/home/$user/$user_projects/11_eclipse/eclipse/cpp-oxygen/eclipse/../../../../../.p2/pool/plugins/fr.ac6.mcu.debug_2.3.1.201811131241/resources/openocd/st_scripts/target/stm32g0x.cfg:45: Error: invalid subcommand “erase_padded_zone 0 enable”
in procedure ‘script’
at file “embedded:startup.tcl”, line 60
at file “zznucleo_g071rb Debug.cfg”, line 29
in procedure ‘flash’ called at file “/home/$user/$user_projects/11_eclipse/eclipse/cpp-oxygen/eclipse/../../../../../.p2/pool/plugins/fr.ac6.mcu.debug_2.3.1.201811131241/resources/openocd/st_scripts/target/stm32g0x.cfg”, line 45

Here is what stm32g0x.cfg line 45 looks like:
“flash erase_padded_zone 0 enable”

I checked the stm32f4x.cfg file and it did not have this line. Indeed, of the 12 cfg files at this location, only those for stm32l4x.cfg, stm32l4plusx.cfg and stm32g0x.cfg.

This is the version of openocd that I am using:
$ openocd --version
Open On-Chip Debugger 0.10.0+dev-00143-gf6449a7 (2019-03-04-01:16)
Licensed under GNU GPL v2

I checked its manual and did not find anything about a “flash erase_padded_zone” command.

Perhaps someone can advise on where I’ve gone wrong or what I can do to fix this. Thanks.

Regards,
J

Prolem went away after a coupgle of restarts of computer and eclipse. Thanks.

Regards,
J


 

Newest Forum Posts

  1. Holy fuck by mkellinghusen, 2020-12-02 22:54
  2. Holy fuck by rhaley-starfish, 2020-12-02 19:46
  3. Unable to Build and Clean Program in STM32CubeIDE by chandlerbing65nm, 2020-12-01 15:25
  4. Holy fuck by jqwpb, 2020-12-01 09:45
  5. Ubuntu 19.04 Debug problems by wigir, 2020-11-29 20:38
  6. SW4STM32 installation on Ubuntu 20.04 LTS by ImedBriki, 2020-11-27 23:43
  7. Serial Printing on STM32F1 using CubeMX by LORDHADES, 2020-11-27 09:04
  8. gdb not connected to openocd for debug by avf1906, 2020-11-23 10:26
  9. STM32F103 + CAN -> microcontroller does not release the frame from FIFO banks by amilo_pa, 2020-11-17 09:08
  10. STWINKT1 as HID by greale, 2020-11-13 13:03

Last-Modified Blogs