SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Ubuntu gksudo deprecated - graphical install does not work

The required program gksudo is deprecated and not available for installation in Ubuntu 18.04, its most recent LTS version.

After some research online, I decided to create an alias using pkexec, which is supposed to do what gksudo did, and is part of the standard Ubuntu installation:

I then run $ gksudo fullpath_to_install_program.run

a dialog window was open asking for the sudo password. After that, however, the install program did not find gksudo and asked if I wanted to run in console (non-graphical) mode. I proceeded to install in console mode.

It seems to have worked. I will get back on that.

Hi guys, this method did not work for me.

Initially the “alias...” generated an error which I assumed was due to the use of 2 single quotes at the beginning and a single quote at the end. Adding another single quote at the end resulted in a “>” prompt and stuck there.

Any help would be appreciated.

Xuraax, thank you for pointing out the typo. It is just single quotes around the alias definition, as shown in my corrected post. BTW, the installation of the STM32 Workbench using “console mode” is working on my 18.04 Lubuntu machine.

It are single quotes which are not present in any formal grammar now.
And it does not work any way on Ubuntu 19.04 Disco Dingo, what ever I tried.

I found a solution however.
If no gksudo, it ought to be created gksudo.
It ought to be created gksudo, with alias in shell, instead of shell alias.
I created executable gksudo in /usr/bin with following context:
pkexec env DISPLAY=:0 XAUTHORITY=/run/user/1000/gdm/Xauthority DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus $1 $2 $3 $4 $5 $6 $7 $8 $9 $10
After I simply ran installer as it actually is gksudo.
However it later came troubles with compliance that replacement does not understand option -D, the same, I afraid, would be with offered shell alias.


Newest Forum Posts

  1. Firmware Installation Process Issue by valkundesuyash@gmail.com, 16:14
  2. STM32F746-Discovery by stanandrzej, 13:55
  3. Can't debug by deksnys4life, 08:16
  4. Can't download StdPeriph library during project creation by klopi90, 2019-12-09 08:46
  5. Building project - subdir.mk error by nupurkohadkar1997, 2019-12-06 18:10
  6. openOCD Wrong device detected by maxim221, 2019-12-06 12:32
  7. STM32429I_Discovery board with printf float support problem by johannes.visser@msc-technologies.eu, 2019-12-05 16:08
  8. malloc heap issue with CubeMX Project by johannes.visser@msc-technologies.eu, 2019-12-05 16:04
  9. Debugger not working by Daniel Jack Morley, 2019-11-27 21:46
  10. Compiler change problem by Lucian Pop, 2019-11-20 17:41

Last-Modified Blogs