SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Cannot program or debug STM32VLDiscovery

I ran into this problem as well when I started using SW4STM32.

The resoultion turned out to be related to the type of USB port you had your board/debugger plugged into. When I plugged my board into a USB 3-compatible port, I saw the same error message. When I plugged my board/debugger into a USB 2 port, I was able to (eventually, after some messing around) get debugging to work.

Try plugging your board into a different USB port and try again.