Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Error executing Debug function: gdb and libncurses.so.5

Hello,

I am using the latest version of openstm32 on Linux and I have problems running the debug function because of a launcher error.

The error is:

__Could not determine GDB version using command: /opt/st/plugins/fr.ac6.mcu.externaltools.arm-none.linux64_1.15.0.201708311556/tools/compiler/bin/arm-none-eabi-gdb --version
/opt/st/plugins/fr.ac6.mcu.externaltools.arm-none.linux64_1.15.0.201708311556/tools/compiler/bin/arm-none-eabi-gdb: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory__

This is because gdb cannot find libncurses.so.5 (I tried to execute gdb manually from shell), however, these are correctly installed on my Debian system.

What is the libncurses’s path gdb is looking for ?

Thank you in advance.
Regards,
Simon

I’ve just installed libncurses5 in ubuntu eaon ermin and the problem solved.

You are right, thank you tang
Regards,
Simon