Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


C project Wizard - "Finish" button inactive

Hi cartu38,

About software:
1) System Workbench release = x64, v2.1 (downloaded 25-08-2017); if I check Ecipse Version in System Workbench, I see: Neon.3 Release (4.6.3) Build id: 20170314-1500
2) Windows 10 Home 64-bit (10.0, Build 15063)
3) Java 8 Update 121 (8.0.1210.13), both 64-bit and 32-bit same version installed

About my attempts:
1) I’ve tried all options in Project Firmware Configurations screen: “No firmware”, “Cube HAL”, “StdPeriph” - same result, “Finish button” inactive.
2) I’ve tried to launch System Workbench like “run as administrator” and usually - no effect;
3) tried choosing different MCUs at MCU configuration screen - same result;
4) Tried default project location, and also changed location of project outside workspace - still no result...