Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


C project Wizard - "Finish" button inactive

Hi,

I have an issue with Ac6: I’m doing everything as usualy, when creating new project, but get a problem. The problem’s details:
1) I’m creating a new project: File => New => C Project
2.1) Typing in Project Name = “TestProject”;
2.2) leave “Use devault location” checkbox marked;
2.3) Project type = Ac6 STM32 MCU Project
2.4) Toolchains = Ac6 STM32 MCU GCC
2.5) Press “Next”
3) Leave everything as is (Debug + Release configurations) and press “Next”
4)Select my board (NUCLEO-F411RE) and press “Next”
5.1) Select “Standard Peripheral Library”, download it;
5.2) ...aaaand. the problem is that “Finish” button is inactive. - pls. see attached screenshot.
Epicfail

What could be the problem? - I double checked, that no important checkboxes or textfields are left empty... however, nothing works...

Extra info: if I’m creating new Workspace, then the first new project there can be created easily - “Finish”button works as it should. The second project can;t be created in workspace :-(
Extra images of all wizard’s screens:
Ac6 1 Ac6 2 Ac6 3

France

Hello Jurist88,

I’ve just got a try (I’m relying on latest System Workbench for STM32 release) : all is working fine on my side, taking care to perform same setups as yours, Finish button is enabled.

Please could you share your environment (System Workbench release, Operating system, java release) ?

Could you have a try too to select another firmware option (No firmware or HAL firmware) just to see if any update on Finish button state ?

Let’s share back your data.
Br.


Hi cartu38,

About software:
1) System Workbench release = x64, v2.1 (downloaded 25-08-2017); if I check Ecipse Version in System Workbench, I see: Neon.3 Release (4.6.3) Build id: 20170314-1500
2) Windows 10 Home 64-bit (10.0, Build 15063)
3) Java 8 Update 121 (8.0.1210.13), both 64-bit and 32-bit same version installed

About my attempts:
1) I’ve tried all options in Project Firmware Configurations screen: “No firmware”, “Cube HAL”, “StdPeriph” - same result, “Finish button” inactive.
2) I’ve tried to launch System Workbench like “run as administrator” and usually - no effect;
3) tried choosing different MCUs at MCU configuration screen - same result;
4) Tried default project location, and also changed location of project outside workspace - still no result...


Update: after 100 attempts, like closing/opening System Wokbench; starting and canceling the project wizard, copying/deleting files, I managed to get “finish” button active and create project (!) - Epic Win;

However after that, for experiment, I tried to create one more project; I repeated all the same actions; aaand again epic fail - “Fnish” button inactive. Trying to understand, what else could matter for project creation...

France

Hello,

Thanks for sharing.

For sure such is quite weird.
Fact number 1 is once project name is set wizard is allowing you to push Next button to move thru wizard’ pages : such is ok on your side according shared snapshots.
Fact number 2 is as soon as you are selecting a target (board), finish button should be enabled allowing you to launch project creation without taking care about firmware options page : sounds such step is already KO on your side ...

Definitively not convinced about, but just in case, if ok to you, could you update your current System Workbench for STM32 ?. 28-08-2017 release is not latest one.

Thanks to share back outcomes.
Br.

Hello,
I’ve done the update (haven’t cleaned the registry files, though - just deleted old and installed new one).
Result - I can get to active Finish button much more frequently (60-80% of attempts)

I’ll try later to test it more thoroughly, probably with screen video. (Now always when I tried to capture screen video, project creation always worked :-D - almost Heisenbug)