SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Target option gone off menu

Last night (5th September 2017) I was notified from within openSTM32 that an update was available. I applied it (look to be new compiler version) and this morning when I tried to program my stm32 I couldn’t find the option “Traget” -> “Program Chip” on my RMB menu. Anyone know how I can restore it?

Hello scopa,

Sounds issue related to latest release playing with an existing project.

Let’s hack your project .project file then let’s refresh it to get Target menu back.

Hack is the following : Let’s add < nature>fr.ac6.mcu.ide.core.MCUSingleCoreProjectNature< /nature> (no space please) to your current .project file nature item(s)

Let’s me know if such is helpful.


Hello cartu38

that worked! Thank you very much.



Sounds latest SystemWorkbench for STM32 update is solving issue. Promoted hack is so useless.


(This was posted slightly before cartu38 provided the fix)
Small update: If I use the “Quick Access” in the top right corner of the screen and type “program chip” then it opens the correct dialogue. Odd that it’s gone off the menu, though.

This has just happened to me with a project I have been working on for months. Suddenly the Target context menu entry is gone. It’s the same for all of my previously working projects too. My SystemWorkbench is up to date as of 16/3/2018. Tried the hack mentioned above and it doesn’t help at all.

Any ideas?



Are you sure you display the “Project Explorer” view on the left pane and not the “Project Navigator” view? Both are very similar but the “Target” menu is only available in the former.

You can restore the normal perspective content by “Windows >> Perspective >> Reset Perspective” if you don’t know how to display again the default views.

Hope this helps,

Bernard (Ac6)

Perfect - thank you @dautrevaux - that’s what I was missing! Glad I asked as now if someone has this question in future there’s a place for them to find an answer :-)