SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Exporting from mbed?

Has anyone had any success exporting a nucleo board from mbed?
I’ve tried but I’ve had lots of problems such as:

  • Program “make” not found in PATH
  • Type ‘uint16_t’ could not be resolved

If anyone can help with this that would be great biggrin



Hello Marcus,

Importing a program generated under mbed in System Workbench for STM32 is a bit cumbersome. To help I have created a documentation page at Importing an mbed program; there is certainly a few rough edges but I hope you will be able to succeed.


Hi Bernard

Thanks for the amazing help, I was expecting hints, not a whole page! This has helped a great deal smile
Do you mind if I reference it or post it on the mbed site?

Thanks again

This explanation is seriously outdated. It will not work on mbed-os 5

The mbed project exporter is bugged for months and still not fixed!
Even if the import procedure is complex ... it worked for me.

Following the page “Importing an mbed program” I still have one error which is:
make: *** blinker.elf Error 1 blinker

What can I do to fix this?
Thanks for any help


Isn’t there any more output in the Console view? Just this line is not very informative...
There is probably a few more text leading to this error.

No thats all it says where blinker is the name of the project. There is no path or location to the error.


Hi Marcus,

I’ve updated the Importing an mbed program page; I made a few mistakes in th eorder of some operations and forget one update to a System Workbench for STM32-povided file.

I hope this time it will work for you; Could you try it and report me any problem?

Thanks in advance,


Hi Bernard

Sorry for the long reply, I’ve been abroad the last two weeks. I’ve just tried the updated method to importing an mbed program and it built without any errors.

Thanks for the help biggrin