SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world. And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download (registration required) various documents highlighting:

System Workbench for STM32

Problem Ubuntu 16.04.2


I have made this morning a clean install of Ubuntu 16.04.2 and installed System Workbench but it doesn’t work as expected. It loads but then is like hanging and it won’t even let me compile.

Yesterday it worked perfectly with Ubuntu 16.04.1.

Have anyone else tried with this new Ubuntu realese and a clean install?

I have already tried both 64bits versions avalaible for linux and I get the same result.

Anyone could help me with this?

Hi. I’ve tried that yesterday on linuxmint 18.1, which is ubuntu 16.04 based. Sadly, it did not work. Eclipse error log showed a lot of dependecy related messages.

I have also tried to “install from Eclipse” method, using version from repos. It did not work also, citing dependency problems (refused to install).

I’m surprised it used to work under Ubuntu 16.04.1 at all. Somewhere on this site it states that only supported version is Ubuntu 14.04, so I gave up and went with it. So far seems to work.

Anyway, i’m very new to stm32, just wanted easy way to start, but as far as I understand there are ways to build, flash and debug without using “System Workbench for stm32” at all.

According to /etc/issue I’m running 16.04.02. I don’t recall if I did a clean install or updated an earlier 16.04 release. Ordinarily I just upgrade for point releases (and major releases where possible.)

Java reports as

hbarta@olive:~$ java -version
openjdk version “1.8.0_121”
OpenJDK Runtime Environment (build 1.8.0_121-8u121-b13-0ubuntu1.16.04.2-b13)
OpenJDK 64-Bit Server VM (build 25.121-b13, mixed mode)

I’m running eclipse Neon (Neon.2 Release (4.6.2))

Did you remember to install other dependencies? Thet’s where I usually mess up following a new install. There is the need to install some 32 bit libraries IIRC (and you may need to add that architecture.)

Dod you try running Eclipse from the command line to see if it puts out any useful diagnostics?

(Apologies for any typos. The forum S/W seems to have defeated the spell checker built into Chrome.)

HankB, did you install System Workbench from already installed Eclipse?



There is a known bug of Eclipse on Ubuntu-16.04 and other recent Linux distributions; please look at this FAQ entryQuestion

Bernard (Ac6)

Which OS are we supposed to use then?
Ubuntu 16.04 is the oldest LTS that is still recommended by Ubuntu.
(Ubuntu 14.04 LTS reached end of life on April 30, 2019.)


I installed the same exact version of Ubuntu in my desktop machine and it worked flawlessly so I tried to do again a clean install of ubuntu with the same thumb drive in my laptop and I got the same problem as before with SW4STM32.

So I tried the solutions in the FAQ shared by Bernard and doing this:

Another way to use GTK version 2 instead of 3 is to modify the eclipse.ini file in the System Workbench for STM32 installation, adding__
__before -showsplash

worked for me.

Hello all,
I have exactly this problem, and setting
in my eclipse.ini, solve it :-)