Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Trouble after update SW6 and CubeMX

The update of SW6 and CubeMX brought me a lot of trouble.The generated project from CubeMX will not compile, make error 258.
To solve this goto Setting and place quotes like this: “weak=attributeweak” and “packed=attributepacked

The forum has deleted the ()

Also old projects will not compile anymore. Lost of files are missing that are there. Copy the project by the only copy method i know, start your project.ioc file to open CubeMX and save as a new project. Generate and import the project. Copy the Src and Inc from the old project and place the quotes as described above. Now you have to do this for all your projects!

Hi,

Our team is working on an update to avoid to manually modify these symbols.
It will add double quote around -D flags when the symbol contains special characters such as ‘(’ or ‘)’
This issue come from the different behavior between Windows command prompt and the new shell interpreter(sh.exe) (added to avoid other issues)

Since the 1.13.0

On the build command line:
-D__weak=__attribute__((weak)) and -D__packed=__attribute__((packed)) 		# Not working anymore but worked until the 1.12.0
-D"__weak=__attribute__((weak))" and -D"__packed=__attribute__((packed))"  # Working
-D__weak="__attribute__((weak))" and -D__packed="__attribute__((packed))"  # Working
"-D__weak=__attribute__((weak))" and "-D__packed=__attribute__((packed))"  # Working but cannot be set by the user (automatic behavior in the next update 1.13.1 when a special char is found)


Sorry for inconvenience.
Kevin
ac6


This issue was fixed by ST in Cube version 4.19.0 that came out about January 18th 2017.

I tried it this evening and generating code works properly again.

Andrei