Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


failed eclipse plug-in update to System Workbench for STM32 v1.12.1 release

I tried all night to update eclipse plug-in to System Workbench for STM32 v1.12.1 release.
I could install previous versions, this time I’m lost.

It always fails with such failing message:

An error occurred while collecting items to be installed
session context was:(profile=epp.package.cpp, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: org.eclipse.update.feature,fr.ac6.feature.mcu.externaltools,1.12.0.201612060912
No repository found containing: osgi.bundle,fr.ac6.mcu.externaltools,1.12.0.201612060912

My setup is the following:

Eclipse IDE for C/C++ Developers
Version: Neon Release (4.6.0)
Build id: 20160613-1800

Windows 7 Home Premium 64 bit (6.1, build 7601)

Java Runtime Environment
JRE 1.8 1.8.0_112 Architecture x86_64
JRE 1.8 1.8.0_111 Architecture x86

Any support is appreciated.

Giacomo

P.S.
Merry Chrismast!

P.P.S.
I have a Ubuntu machine where I could update SW4STM32 at least.


@ bing: Thank You for Your support.
I didn’t understood the whole site location thing, but after looking at URL You gave me, I tried to update eclipse with

Name: System Workbench for STM32 - Bare Machine edition
Location: http://www.openstm32.org/Eclipse-updates/org.openstm32.system-workbench.betaQuestion

In this special case, I have a different error and it is the following:

An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
session context was:(profile=epp.package.cpp, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
Error reading signed content.
Exception in opening zip file: C:\eclipse\plugins\fr.ac6.mcu.debug_1.11.2.201612060912

After all, I didn’t found a work around.

Giacomo

Hello Giacomo

I used http://www.ac6-tools.com/Eclipse-updates/org.openstm32.system-workbench.site/Question as the install site and selected only 201611241417 versions. (I had to remove “Show only the latest versions of available software” in the Install dialogue box. This seems to install correctly on Ubuntu 16.04.

I saw this problem when I tried to install updates - similar to http://www.openstm32.org/tiki-view_forum_thread.php?forumId=7&threadId=4205Question

Hope that helps and happy new year
Av