SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Cannot access C/C++ build settings anymore on a fresh install of sytem workbench ?


I get a error message window “The current displayed page contains invalid values”
when trying to access C/C++ build -> settings from Project Properties
Same problem for some another items: Path & Symbols, etc.

Tried some recipes found while googling about this Eclipse problem (?), nothing worked...

Using workbench under Ubuntu 16.10. Same problem on 2 different machines after a fresh install and same problem with new or old projects re-imported.


Are you checking the settings of Ac6 projects?

Yes, AC6 Settings.
It seems System WB works OK till Ubuntu 16.04
This problem occurs only in 16.10 and I have also the same problem in Fedora 25 + buggy windows resizing.
I know these distros are not supported. Eclipse AC6 too old for the new distributions !



Did you look at this FAQ entry?Question It may solve your problem (it’s a known Eclipse problem, that seems to be still present in Neon).

Bernard (Ac6)

Thanks. It solves the problem (export SWT_GTK3=0)