Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


AC6 + ST-Link V2 + SWD programming

I already tried that, but the custom config seems to be ignored, as I wrote in my other post from april. (nothing changed until today - tried it again)
I’m using linux. and also the board-definition doesn’t work.
It doesn’t store anything, and always asks me to enter a new board-definition.

For me it seems, that the Software ist nearly untested with linux, and thats very frustrating. (Not shure, if the situation is much better with windows)

Currently I’m evaluating changing to another framework (ARM-Plugin & Co), because I can’t see any effort in solving all this Problems.

Instead of fixing Bugs, you create new ones like in the 1.9-Version, where debugging was inmpossible, and it took several days to fix....
Fortunaly I’m a hobbyist and don’t have to earn my money with programming, but that is inakzeptable!

Harry