Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


openocd binary not found

Dear all,

I have changed the directory architecture of my project, recreate a new one and now i get the message “openocd binary not found” when I launch the debugger. Before I did the change it worked fine. Where can I get the declaration of “openstm32_openocd_path” variable used by Debug Configuration.
I use version 1.1.0
Thanks

France

Hi Guy,

What do yo mean by changing the directory architecture of your project and create a new one? why creating a new project afetr changing the directory structure? What kind of project did you exactly create?

The openstm32_openocd_path is defined by the openocd plugin and does not depend on the project directory structure, so I don’t understand why changing it could break it.

Bernard


Hi Bernard,

I changed the directory tree with the Windows Explorer, because I have now 2 firmwares to design with 2 differents uC.
I used C++ project with Makefile project type.
During this moving may be I have lost or removed the settings.
I will redo from scratch.
Regards,


Hello,

I’ve updated my framework AC6 to last version 1.6.0 and now get the error message:

OpenOCD Binary not found
when starting a debug session.

I reinstalled my eclipse framework which is a terrible solution. And the issue remains.

Can you help about this ?

Thanks for your help,
Best regards,
Sylvain


If you go into your debug configuration, under the debugger tab, can you change the GDB command and OpenOCD command to point directly to the executable and avoid openstm32_openocd_path?

I had the same problem for a while, I believe pointing directly to the executable worked, but to really get the path variable correct I had to reinstall system workbench and OpenOCD. I don’t remember what order I used, it was not a fun time.


Recreating the workspace directory (especially workspace/.metadata) solved this issue.

Hi guys,

the solution would be going to “Debug configuration” and delete the selected configuration and recreate it.


 

Newest Forum Posts

  1. Firmware Installation Process Issue by valkundesuyash@gmail.com, 2019-12-12 16:14
  2. STM32F746-Discovery by stanandrzej, 2019-12-12 13:55
  3. Can't debug by deksnys4life, 2019-12-12 08:16
  4. Can't download StdPeriph library during project creation by klopi90, 2019-12-09 08:46
  5. Building project - subdir.mk error by nupurkohadkar1997, 2019-12-06 18:10
  6. openOCD Wrong device detected by maxim221, 2019-12-06 12:32
  7. STM32429I_Discovery board with printf float support problem by johannes.visser@msc-technologies.eu, 2019-12-05 16:08
  8. malloc heap issue with CubeMX Project by johannes.visser@msc-technologies.eu, 2019-12-05 16:04
  9. Debugger not working by Daniel Jack Morley, 2019-11-27 21:46
  10. Compiler change problem by Lucian Pop, 2019-11-20 17:41

Last-Modified Blogs