SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

Can't enter to debug session


my PC is running ubuntu 14.04 kernel v3.13.0-46-generic

I’m using openstm32 on eclipse luna for eval board NUCLEO-L073RZ and set up a project.
Compile ok but I can’t enter debug session using stlinkv2-1 usb link:

GDB output:

GNU gdb (GNU Tools for ARM Embedded Processors)
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type “show copying”
and “show warranty” for details.
This GDB was configured as “host=i686-linux-gnu target=arm-none-eabi”.
For bug reporting instructions, please see:

error prompt after a few seconds:

Error in final launch sequence
Failed to execute MI command:
-target-select remote localhost:3333

Error message from debugger back end:
localhost:3333: Connection timed out.
localhost:3333: Connection timed out.

What am I missing ? Maybe some access right ? Any driver installation added to openstm 32 install ?

thanks for your help,

Hello Sylvain,

Sorry, but this board/mcu is not yet supported by System Workbench. You can manage to compile by configuring the project manually as you probably have done, but you will not be able to debug as some specific support for this target is required inside OpenOCD.

Kind regards,


I have the same isue with the STM32L152D_EVAL, I cannot start the debugger.
I get the exact same eror message.

I have no problem with the NUCLEO-L152RE, with this board the debugging works fine.


I’m having same issue on windows xp with Nucleo-L053R8.

Here is some debug data I could get:

Open On-Chip Debugger 0.9.0-dev-00101-g3a546c5-dirty (2014-09-23-14:54)
Licensed under GNU GPL v2
For bug reports, read
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
Info : This adapter doesn’t support configurable speed
Info : STLINK v2 JTAG v20 API v2 SWIM v4 VID 0x0483 PID 0x374B
Info : using stlink api v2
Info : Target voltage: 3.238345
Error: init mode failed
in procedure ‘init’
in procedure ‘ocd_bouncer’
in procedure ‘transport’
in procedure ‘init’

Prompted error :
Error in final launch sequence
Failed to execute MI command:
-target-select remote localhost:3333

Error message from debugger back end:
localhost:3333: The system tried to join a drive to a directory on a joined drive.
localhost:3333: The system tried to join a drive to a directory on a joined drive.

This board should work, isn’t ? Do you have an idea of what should be done ?



Jumpers on the board were not correctly set. My bad.


The same problem here, only with the F05-Nucleo!

I also got the same problem. I am using stm32f4Discovery board(stm32f407vg) which is having ST-Link V2(not ST-link V2-1) Flasher/Debugger. But the Debugger configuration in eclipse is uisng ST-Linkv2-1 openocd config in it’s config file.

I just chaned the openocd config file in plugins directory(file path: /plugins/fr.ac6.mcu.debug_1.8.0.201603291114/resources/openocd/scripts/st_board/stm32f407g_disc1.cfg).

I modified “source find interface/stlink-v2-1.cfg” to “source find interface/stlink-v2.cfg” in the above file.

After this change I am able to connect to the board and everything is fine.



Hi Harsha,

Be careful, looking at your message it seems that you are using an stm32f4discovery board, which indeed includes an STLink-V1 probe, but the script you use is the one for the stm32f407g-disc1, which use the same chip, but includes an STLink-V2-1...

That mean that you probably select the wrong board when creating your project... You should probably delete (do not click “Delete content on disk”) and re-create your project (in the same directory) using the correct board, then port the changes you may have done to the project properties; changes to source files (edits, adds, etc.) will be kept automatically.

Hope this helps,

Bernard (Ac6)