SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32

gdb issue with 429 discovery

I’m getting this error when I try to build and debug for the 429 discovery board.

Error in final launch sequence
Failed to execute MI command:
-target-select remote localhost:3333

Error message from debugger back end:
localhost:3333: The system tried to join a drive to a directory on a joined drive.
localhost:3333: The system tried to join a drive to a directory on a joined drive.


I have been working with the 401 Nucleo, 746 Discovery and 429 Discovery boards. I have been using STM32CubeMX to make a configuration, generate code for SW4STM32, build it with System Workbench.

On the 401 Nucleo and 746 Discovery boards, I can create and run applications. On the 429 Discovery, I get that error.

Anyone else seen this?

The error was in selecting STLink V2-1 for the 429 DIscovery.

That board uses STLink V2.

Could you expand a bit on what you found to fix this problem? I am having the same issue with an STM32F407 Discovery board.
I am new to Workbench for STM32 (and to Eclipse), I can’t find anything for selecting the debugger type (STLink V2). I know it’s an STLINK because I can use the STM32 ST-LINK Utility to program the board with a HEX file but I keep hitting a wall when I try to do debugging.

Thanks for any pointers.



In fact there is two f429 disco board :

  • STM32F429I-DISCO : with STLINK V2
  • STM32F429I-DISC1 : with STLINK V2-1