Loading...
 

SW4STM32 and SW4Linux fully supports the STM32MP1 asymmetric multicore Cortex/A7+M4 MPUs

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4.
You can get more information from the ac6-tools website and download two short videos (registration required) highlighting:

System Workbench for STM32


Is there any working cfg for stm32L0 ???

I have searched whole internet, there were many propositions what do add/remove from cfg files but none of them worked with my 32L0538DISCOVERY.

Please help neutral

After creation of clean project for my board, building it and running default run configuration i got such output:

Open On-Chip Debugger 0.9.0-dev-00418-g9afb8b4-dirty (2015-09-28-12:09)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
adapter speed: 300 kHz
adapter_nsrst_delay: 100
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
srst_only separate srst_nogate srst_open_drain connect_deassert_srst
Info : Unable to match requested speed 300 kHz, using 240 kHz
Info : Unable to match requested speed 300 kHz, using 240 kHz
Info : clock speed 240 kHz
Info : STLINK v2 JTAG v25 API v2 SWIM v13 VID 0x0483 PID 0x374B
Info : using stlink api v2
Info : Target voltage: 3.217323
Error: init mode failed (unable to connect to the target)
in procedure ‘program’
in procedure ‘init’ called at file “embedded:startup.tcl”, line 473
in procedure ‘ocd_bouncer’

    • OpenOCD init failed **

shutdown command invoked


I am able to connect and programm board via stlink utility.
After 4 days of trying to debug via Eclipse I’m sick and tired :-(
I will appreciate for any advice

I feel your pain. I had some hard time myself to get my stm32l152 discovery board running initially. Too many possible pitfalls.

Then I started with STM32Cube which has lots of sample projects.

Just simply download the STM32cubeL0.zip archive. You’ll find it on the STM web page.
This includes bunch of examples for the L0.
Just load one at a time in ac6/system workbench. Build it and try it.

good luck

Mat


Tunisia

Hello

Can you please tell us which version of SW4STM32 you are using ?
And the modifications you have applied to cfg file ?

Regards,
tarekb

I installed the linux and win based version from the webpage (1.3). I used this successfully for my first builds.
Later I updated (you’ll get a popup notice) and everything is working fine with
my L152 and L4 discovery board

Again for you nucleo I suggest download the STM32CubeL0.zip file from STM. Lots of exampel and great way to start.

mat


I use latest stable 64-bit build downloaded from this site

http://www.openstm32.org/Downloading+the+System+Workbench+for+STM32+installer?structure=DocumentationQuestion

Clear installation of Win7 + latest java

I have upgraded st-link firmware of the discovery board
I have updated all plugins on eclipse
It makes no sense to tell you about the changes applied cuz none of them wokrs.

I’m generating simples default project witho only hal and no other libraries. 7 workings are generating which looks like this:
Invalid project path: Include path not found (C:\Ac6\workspace\HelloSTM32\Utilities\Components\hx8347d).
So i removes that paths from settings. After that project builds succesfully.

Then I go to debug configuration, double click on “ac6 stm32 debigging” and try to run it. Accept alerts from windows firewall and the end of story.

“Error: init mode failed (unable to connect to the target)”

and pop-up window with info:
“Failed to execute MI command:
-target-select remote localhost:3333”



Mat, it’s not problem with my project. It’s problem with configuration files to run openocd. I’ll attach those that I use.

I did a couple things to get debug on a Discovery L4 board working from a Windows 10 platform:

1. Update Windows USB drivers using Zadig

2. Update the ST-Link firmware

It sounds like you’ve already updated the ST-Link firmware, but the Zadig drivers might be worth a try. I’m not all that knowledeable in the area, but as I understand it openocd depends on lib_usb in Newlib ..... and the Zadig drivers add support for this to WIndows. I found some directions to do this online and it worked for me.

I’m also using STM32CubeMX to generate all the setup for my project, then importing it as described in the OpenSTM32 pages. I note the debug configuration for this is for the imported project, and I followed the procedure to set “Manual spec” and choosing Debug Device: ST-LinkV2-1 and Debug interface: SWD.